aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/pugixml/pugixml_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/pugixml/pugixml_1.14.bb')
-rw-r--r--meta-oe/recipes-devtools/pugixml/pugixml_1.14.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/pugixml/pugixml_1.14.bb b/meta-oe/recipes-devtools/pugixml/pugixml_1.14.bb
new file mode 100644
index 0000000000..458958edf5
--- /dev/null
+++ b/meta-oe/recipes-devtools/pugixml/pugixml_1.14.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Light-weight C++ XML Processing Library"
+DESCRIPTION = "pugixml is a C++ XML processing library, which consists of a \
+DOM-like interface with rich traversal/modification capabilities, \
+an extremely fast XML parser which constructs the DOM tree from \
+n XML file/buffer, and an XPath 1.0 implementation for complex \
+data-driven tree queries."
+HOMEPAGE = "https://pugixml.org/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://readme.txt;beginline=29;endline=52;md5=ad370df61d83846cf9e4726244671201"
+
+SRC_URI = "https://github.com/zeux/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
+SRC_URI[sha256sum] = "2f10e276870c64b1db6809050a75e11a897a8d7456c4be5c6b2e35a11168a015"
+
+UPSTREAM_CHECK_URI = "https://github.com/zeux/${BPN}/releases"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DBUILD_PKGCONFIG=ON \
+ -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ "
+
+BBCLASSEXTEND = "native nativesdk"