aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb')
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb b/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb
index 9b696906e8..209bb47e8e 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb
+++ b/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.0.bb
@@ -15,10 +15,16 @@ DEPENDS = "protobuf-native protobuf"
PV .= "+git${SRCPV}"
SRCREV = "dac1a65feac4ad72f612aab99f487056fbcf5c1a"
-SRC_URI = "git://github.com/protobuf-c/protobuf-c.git"
+SRC_URI = "git://github.com/protobuf-c/protobuf-c.git \
+ file://0001-protobuf-c-fix-compile-error-with-protobuf-3.6.0.1.patch \
+"
S = "${WORKDIR}/git"
+#make sure c++11 is used
+CXXFLAGS += "-std=c++11"
+BUILD_CXXFLAGS += "-std=c++11"
+
inherit autotools pkgconfig
PACKAGE_BEFORE_PN = "${PN}-compiler"