aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb')
-rw-r--r--meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb b/meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb
index 27a7f9da7c..be9704a313 100644
--- a/meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb
+++ b/meta-oe/recipes-devtools/perl/libparse-yapp-perl_1.21.bb
@@ -5,7 +5,7 @@ with perl object oriented interface."
HOMEPAGE = "http://search.cpan.org/dist/Parse-Yapp/"
SECTION = "libs"
-LICENSE = "Artistic-1.0 | GPL-1.0+"
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
LIC_FILES_CHKSUM = "file://lib/Parse/Yapp.pm;beginline=508;endline=521;md5=41a4542fcde97a600c9de0d782a90256"
@@ -18,4 +18,8 @@ S = "${WORKDIR}/Parse-Yapp-${PV}"
inherit cpan
+do_install:append() {
+ sed -i "s:^#!.*:#!/usr/bin/env perl:" ${D}${bindir}/yapp
+}
+
BBCLASSEXTEND = "native"