aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/packagegroups
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/packagegroups')
-rw-r--r--meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb b/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb
index 3ad9b55577..b9e5a296ce 100644
--- a/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb
+++ b/meta-oe/recipes-devtools/packagegroups/packagegroup-sdk-target.bb
@@ -2,9 +2,13 @@ DESCRIPTION = "Packages required for a target (on-device) SDK"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+PR = "r1"
+
inherit packagegroup allarch
-RPROVIDES_${PN} = "packagegroup-native-sdk"
+RPROVIDES_${PN} += "packagegroup-native-sdk task-sdk-target task-native-sdk"
+RREPLACES_${PN} += "packagegroup-native-sdk task-sdk-target task-native-sdk"
+RCONFLICTS_${PN} += "packagegroup-native-sdk task-sdk-target task-native-sdk"
RDEPENDS_${PN} = "gcc-symlinks g++-symlinks cpp cpp-symlinks \
binutils-symlinks \
perl-modules \