aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/openocd/openocd_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/openocd/openocd_git.bb')
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd_git.bb26
1 files changed, 17 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb
index 20bc663f98..1a15e53b8f 100644
--- a/meta-oe/recipes-devtools/openocd/openocd_git.bb
+++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -4,14 +4,22 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "libusb-compat libftdi"
RDEPENDS_${PN} = "libusb1"
-SRC_URI = "git://repo.or.cz/openocd.git \
- file://0001-Add-fallthrough-comments.patch \
- file://0002-Workaround-new-warnings-generated-by-GCC-7.patch \
- file://0003-armv7a-Add-missing-break-to-fix-fallthrough-warning.patch \
- file://0004-Fix-overflow-warning.patch \
- file://0005-command-Move-the-fall-through-comment-to-right-scope.patch \
+SRC_URI = " \
+ git://repo.or.cz/openocd.git;protocol=http;name=openocd \
+ git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
+ git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
+ git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
+ file://0001-Add-fallthrough-comments.patch \
+ file://0002-Workaround-new-warnings-generated-by-GCC-7.patch \
+ file://0003-armv7a-Add-missing-break-to-fix-fallthrough-warning.patch \
+ file://0004-Fix-overflow-warning.patch \
+ file://0005-command-Move-the-fall-through-comment-to-right-scope.patch \
"
-SRCREV = "1025be363e2bf42f1613083223a2322cc3a9bd4c"
+SRCREV_FORMAT = "openocd"
+SRCREV_openocd = "1025be363e2bf42f1613083223a2322cc3a9bd4c"
+SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
+SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787"
+SRCREV_libjaylink = "699b7001d34a79c8e7064503dde1bede786fd7f0"
PV = "0.10+gitr${SRCPV}"
S = "${WORKDIR}/git"
@@ -20,10 +28,10 @@ inherit pkgconfig autotools-brokensep gettext
BBCLASSEXTEND += "nativesdk"
-EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html "
+EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html"
do_configure() {
- ./bootstrap
+ ./bootstrap nosubmodule
oe_runconf ${EXTRA_OECONF}
}