aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb')
-rw-r--r--meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb b/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
new file mode 100644
index 0000000000..d50366843e
--- /dev/null
+++ b/meta-oe/recipes-devtools/nodejs/com.webos.app.minimal.bb
@@ -0,0 +1,28 @@
+LICENSE = "CLOSED"
+
+SRCREV = "b63c3934878be75e53713c5ec1cae3d12a87088d"
+SRC_URI = "git://github.com/shr-project/com.webos.app.minimal;protocol=https;branch=webpack \
+ npmsw://${THISDIR}/${BPN}/npm-shrinkwrap.json \
+"
+S = "${WORKDIR}/git"
+
+DEPENDS = "nodejs-native strace-native"
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ :
+}
+
+do_install() {
+ export UV_USE_IO_URING=0
+ strace -ff -v ${STAGING_BINDIR_NATIVE}/node node_modules/webpack-cli/bin/cli.js -o ${D}/test
+}
+
+FILES:${PN} += "test"
+
+# to make sure this isn't cached in sstate-cache after showing just a warning in package_qa
+# http://errors.yoctoproject.org/Errors/Details/739941/
+ERROR_QA:append = " host-user-contaminated"