aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/msgpack/msgpack-cpp_4.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/msgpack/msgpack-cpp_4.0.2.bb')
-rw-r--r--meta-oe/recipes-devtools/msgpack/msgpack-cpp_4.0.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/msgpack/msgpack-cpp_4.0.2.bb b/meta-oe/recipes-devtools/msgpack/msgpack-cpp_4.0.2.bb
new file mode 100644
index 0000000000..f66a00bd84
--- /dev/null
+++ b/meta-oe/recipes-devtools/msgpack/msgpack-cpp_4.0.2.bb
@@ -0,0 +1,22 @@
+SUMMARY = "MessagePack implementation for C and C++"
+DESCRIPTION = "MessagePack is an efficient binary serialization format. It's like JSON. but fast and small"
+HOMEPAGE = "http://msgpack.org/index.html"
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \
+ file://COPYING;md5=0639c4209b6f2abf1437c813b208f2d3 \
+ file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \
+ "
+
+PV .= "+git${SRCPV}"
+
+SRC_URI = "git://github.com/msgpack/msgpack-c;branch=cpp_master \
+ "
+SRCREV = "3bdbf0d2ee75d46d71afa691a594777d89a22cf7"
+
+DEPENDS += "boost"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+BBCLASSEXTEND += "native nativesdk"