aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/ltp-ddt/ltp-ddt')
-rw-r--r--meta-oe/recipes-devtools/ltp-ddt/ltp-ddt/0001-KERNEL_INC-in-modern-kernel-should-point-at-toplevel.patch40
-rw-r--r--meta-oe/recipes-devtools/ltp-ddt/ltp-ddt/0001-wdt_test_suite-Make-sure-to-include-generated-header.patch34
2 files changed, 74 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt/0001-KERNEL_INC-in-modern-kernel-should-point-at-toplevel.patch b/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt/0001-KERNEL_INC-in-modern-kernel-should-point-at-toplevel.patch
new file mode 100644
index 0000000000..0b4ee64551
--- /dev/null
+++ b/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt/0001-KERNEL_INC-in-modern-kernel-should-point-at-toplevel.patch
@@ -0,0 +1,40 @@
+From e0fc5bea466c16b9d754a8ac8d0453e396678a2c Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 19 Feb 2014 20:28:07 -0800
+Subject: [PATCH] KERNEL_INC in modern kernel should point at toplevel
+ kerneldir
+
+Reason is kernel headers are not only in toplevel
+include/ but also in toplevel arch/ dir
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 031d8bc..73e9b3c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -245,15 +245,15 @@ endif
+
+ modules_edma:
+ @echo "Going to compile edma test kernel modules for $(PLATFORM)"
+- cd testcases/ddt/edma_test_suite/src/kernel; make CROSS_COMPILE=$(CROSS_COMPILE) KERNEL_DIR=$(KERNEL_INC)/.. PLATFORM=$(PLATFORM)
++ cd testcases/ddt/edma_test_suite/src/kernel; make CROSS_COMPILE=$(CROSS_COMPILE) KERNEL_DIR=$(KERNEL_INC) PLATFORM=$(PLATFORM)
+
+ modules_gpio:
+ @echo "Going to compile gpio test kernel modules for $(PLATFORM)"
+- cd testcases/ddt/gpio_test_suite/src/kernel; make CROSS_COMPILE=$(CROSS_COMPILE) KERNEL_DIR=$(KERNEL_INC)/.. PLATFORM=$(PLATFORM)
++ cd testcases/ddt/gpio_test_suite/src/kernel; make CROSS_COMPILE=$(CROSS_COMPILE) KERNEL_DIR=$(KERNEL_INC) PLATFORM=$(PLATFORM)
+
+ modules_ipc:
+ @echo "Going to compile IPC test kernel modules for $(PLATFORM)"
+- cd testcases/ddt/ipc_test_suite/src/kernel; make CROSS_COMPILE=$(CROSS_COMPILE) KERNEL_DIR=$(KERNEL_INC)/.. PLATFORM=$(PLATFORM)
++ cd testcases/ddt/ipc_test_suite/src/kernel; make CROSS_COMPILE=$(CROSS_COMPILE) KERNEL_DIR=$(KERNEL_INC) PLATFORM=$(PLATFORM)
+
+ modules: $(MODULES_TO_BUILD)
+
+--
+1.9.0
+
diff --git a/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt/0001-wdt_test_suite-Make-sure-to-include-generated-header.patch b/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt/0001-wdt_test_suite-Make-sure-to-include-generated-header.patch
new file mode 100644
index 0000000000..56b0333ca4
--- /dev/null
+++ b/meta-oe/recipes-devtools/ltp-ddt/ltp-ddt/0001-wdt_test_suite-Make-sure-to-include-generated-header.patch
@@ -0,0 +1,34 @@
+From 4a8f24892514cd5e4d11b9105c843db49eea921b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 19 Feb 2014 19:41:33 -0800
+Subject: [PATCH] wdt_test_suite: Make sure to include generated headers
+
+This makes sure that its using the generated headers
+and not the raw headers from kernel, generated headers
+are built for the given machine already when kernel is
+built and are available in configured/compiled kernel tree
+already
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ testcases/ddt/wdt_test_suite/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/testcases/ddt/wdt_test_suite/Makefile b/testcases/ddt/wdt_test_suite/Makefile
+index 90a6a90..22a1cfd 100644
+--- a/testcases/ddt/wdt_test_suite/Makefile
++++ b/testcases/ddt/wdt_test_suite/Makefile
+@@ -20,8 +20,8 @@ INCLUDES = -I $(KERNEL_INC) -I src/interface/common -I ../utils/user
+ INCLUDES = -I src/parser \
+ -I src/interface/common \
+ -I ../utils/user \
+- -I $(KERNEL_INC)/include \
+- -I $(KERNEL_INC)/arch/arm/include
++ -I $(KERNEL_INC)/include/generated \
++ -I $(KERNEL_INC)/arch/arm/include/generated \
+
+ #List of source files- Update this on adding a new C file
+ SOURCES := \
+--
+1.9.0
+