aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb')
-rw-r--r--meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb
index 950b64ee9b..7e0272f898 100644
--- a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb
+++ b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.3.0.bb
@@ -13,14 +13,10 @@ SECTION = "libs"
LIC_FILES_CHKSUM = "file://COPYING;md5=ea061f8731d5e6a5761dfad951ef5f5f"
-SRC_URI = "git://github.com/jemalloc/jemalloc.git;branch=master;protocol=https \
+SRC_URI = "git://github.com/jemalloc/jemalloc.git;branch=dev;protocol=https \
file://run-ptest \
"
-
-# Workaround for https://github.com/llvm/llvm-project/issues/52765
-SRC_URI:append:libc-glibc:toolchain-clang = " file://0001-test-Disable-optimization-with-clang-for-aligned_all.patch "
-
-SRCREV = "54eaed1d8b56b1aa528be3bdd1877e59c56fa90c"
+SRCREV = "630434bb0ac619f7beec927569782d924c459385"
S = "${WORKDIR}/git"
@@ -29,6 +25,9 @@ inherit autotools ptest
EXTRA_AUTORECONF += "--exclude=autoheader"
EXTRA_OECONF:append:libc-musl = " --with-jemalloc-prefix=je_"
+# For some reason VERSION file populated only in tarball distribution.
+# Adding jemalloc version since this recipe is using source code from git tag
+EXTRA_OECONF:append = " --with-version=${PV}-0-g${SRCREV} --enable-xmalloc"
do_install:append() {
sed -i -e 's@${STAGING_DIR_HOST}@@g' \
@@ -42,10 +41,13 @@ do_compile_ptest() {
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
- subdirs="test/unit test/integration test/stress "
+ subdirs="unit integration stress "
for tooltest in ${subdirs}
do
- cp -r ${B}/${tooltest} ${D}${PTEST_PATH}/tests
+ cp -r ${B}/test/${tooltest} ${D}${PTEST_PATH}/tests
+ if find ${S}/test/${tooltest}/ -name '*.sh' -print -quit | grep -q .; then
+ cp ${S}/test/${tooltest}/*.sh ${D}${PTEST_PATH}/tests/${tooltest}
+ fi
done
find ${D}${PTEST_PATH}/tests \( -name "*.d" -o -name "*.o" \) -exec rm -f {} \;
}