aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/ctags/ctags_5.9.20210905.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/ctags/ctags_5.9.20210905.0.bb')
-rw-r--r--meta-oe/recipes-devtools/ctags/ctags_5.9.20210905.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ctags/ctags_5.9.20210905.0.bb b/meta-oe/recipes-devtools/ctags/ctags_5.9.20210905.0.bb
new file mode 100644
index 0000000000..3289436fa2
--- /dev/null
+++ b/meta-oe/recipes-devtools/ctags/ctags_5.9.20210905.0.bb
@@ -0,0 +1,34 @@
+# Copyright (C) 2015 Igor Santos <igor.santos@aker.com.br>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Universal Ctags"
+DESCRIPTION = "Universal Ctags is a multilanguage reimplementation of the \
+ Unix ctags utility. Ctags generates an index of source code \
+ definitions which is used by numerous editors and utilities \
+ to instantly locate the definitions."
+
+HOMEPAGE = "https://ctags.io/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+inherit autotools-brokensep pkgconfig manpages
+
+SRCREV = "ca81123303640582358ce7b8a4e466615950a1f7"
+SRC_URI = "git://github.com/universal-ctags/ctags"
+
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG ??= " \
+ readcmd \
+ xml \
+ json \
+ yaml \
+"
+PACKAGECONFIG[readcmd] = "--enable-readcmd,--disable-readcmd"
+PACKAGECONFIG[etags] = "--enable-etags,--disable-etags"
+PACKAGECONFIG[xml] = "--enable-xml,--disable-xml,libxml2"
+PACKAGECONFIG[json] = "--enable-json,--disable-json,jansson"
+PACKAGECONFIG[seccomp] = "--enable-seccomp,--disable-seccomp,libseccomp"
+PACKAGECONFIG[yaml] = "--enable-yaml,--disable-yaml,libyaml"
+PACKAGECONFIG[manpages] = ",,python3-docutils-native"