aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto/botan
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-crypto/botan')
-rw-r--r--meta-oe/recipes-crypto/botan/botan_3.2.0.bb (renamed from meta-oe/recipes-crypto/botan/botan_2.14.0.bb)19
1 files changed, 9 insertions, 10 deletions
diff --git a/meta-oe/recipes-crypto/botan/botan_2.14.0.bb b/meta-oe/recipes-crypto/botan/botan_3.2.0.bb
index 13b2c6649b..5eff2d383e 100644
--- a/meta-oe/recipes-crypto/botan/botan_2.14.0.bb
+++ b/meta-oe/recipes-crypto/botan/botan_3.2.0.bb
@@ -1,21 +1,20 @@
SUMMARY = "Crypto and TLS for C++11"
HOMEPAGE = "https://botan.randombit.net"
LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://license.txt;md5=a02e03c8fa2c5e7b9b3fcc1b9811fd3b"
+LIC_FILES_CHKSUM = "file://license.txt;md5=f5254d3abe90ec5bb82c5694ff751546"
SECTION = "libs"
SRC_URI = "https://botan.randombit.net/releases/Botan-${PV}.tar.xz"
-SRC_URI[md5sum] = "ebc68c08b99bbc4b4fc9bdbfad398b02"
-SRC_URI[sha256sum] = "0c10f12b424a40ee19bde00292098e201d7498535c062d8d5b586d07861a54b5"
+SRC_URI[sha256sum] = "049c847835fcf6ef3a9e206b33de05dd38999c325e247482772a5598d9e5ece3"
S = "${WORKDIR}/Botan-${PV}"
inherit python3native siteinfo lib_package
CPU ?= "${TARGET_ARCH}"
-CPU_x86 = "x86_32"
-CPU_armv7a = "armv7"
-CPU_armv7ve = "armv7"
+CPU:x86 = "x86_32"
+CPU:armv7a = "armv7"
+CPU:armv7ve = "armv7"
do_configure() {
python3 ${S}/configure.py \
@@ -41,13 +40,13 @@ do_compile() {
}
do_install() {
oe_runmake install
- sed -i -e "s|${D}||g" ${D}${libdir}/pkgconfig/botan-2.pc
+ sed -i -e "s|${D}||g" ${D}${libdir}/pkgconfig/botan-3.pc
}
PACKAGES += "${PN}-python3"
-FILES_${PN}-python3 = "${libdir}/python3"
+FILES:${PN}-python3 = "${libdir}/python3"
-RDEPENDS_${PN}-python3 += "python3"
+RDEPENDS:${PN}-python3 += "python3"
-COMPATIBLE_HOST_riscv32 = "null"
+COMPATIBLE_HOST:riscv32 = "null"