aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb')
-rw-r--r--meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb31
1 files changed, 16 insertions, 15 deletions
diff --git a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
index de23dcd5b9..1c1a02d0bf 100644
--- a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
+++ b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
@@ -1,8 +1,9 @@
SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process."
DESCRIPTION = "Plymouth is an application that runs very early in the boot process \
- (even before the root filesystem is mounted!) that provides a \
- graphical boot animation while the boot process happens in the background."
+ (even before the root filesystem is mounted!) that provides a \
+ graphical boot animation while the boot process happens in the background. \
+"
HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth"
SECTION = "base"
@@ -19,10 +20,10 @@ SRC_URI = "http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.ta
SRC_URI[md5sum] = "ff420994deb7ea203df678df92e7ab7d"
SRC_URI[sha256sum] = "2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f"
-EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation\
- --with-logo=${LOGO} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \
- "
+EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \
+ --with-logo=${LOGO} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \
+"
PACKAGECONFIG ??= "pango initrd"
PACKAGECONFIG_append_x86 = " drm"
@@ -38,15 +39,15 @@ LOGO ??= "${datadir}/plymouth/bizcom.png"
inherit autotools pkgconfig systemd
do_install_append() {
- install -d ${D}${systemd_unitdir}/system
- install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system
- install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system
- # Remove /var/run from package as plymouth will populate it on startup
- rm -fr "${D}${localstatedir}/run"
-
- if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
- rm -rf "${D}${libexecdir}"
- fi
+ install -d ${D}${systemd_unitdir}/system
+ install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system
+ install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system
+ # Remove /var/run from package as plymouth will populate it on startup
+ rm -fr "${D}${localstatedir}/run"
+
+ if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
+ rm -rf "${D}${libexecdir}"
+ fi
}
PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"