aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb')
-rw-r--r--meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb
new file mode 100644
index 0000000000..e6add2bb26
--- /dev/null
+++ b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.12.4.bb
@@ -0,0 +1,21 @@
+require fakeroot_${PV}.bb
+
+SRC_URI += "file://fix-prefix.patch"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = "--program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+NATIVE_INSTALL_WORKS = "1"
+
+RDEPENDS_${PN} = "util-linux-native"
+
+SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
+SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"