aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb')
-rw-r--r--meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb b/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
new file mode 100644
index 0000000000..32ed7dbfd3
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "dbus forwarding daemon"
+LICENSE = "LGPLv2.1+"
+DEPENDS = "dbus dbus-glib"
+SRCREV = "1226a0a1374628ff191f6d8a56000be5e53e7608"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.collabora.co.uk/git/user/alban/dbus-daemon-proxy;protocol=git"
+S = "${WORKDIR}/git"
+
+do_compile() {
+ ${CC} ${LDFLAGS} `pkg-config --cflags --libs dbus-glib-1` -o dbus-daemon-proxy dbus-daemon-proxy.c
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 dbus-daemon-proxy ${D}${bindir}
+}
+