aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iwd/iwd_0.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/iwd/iwd_0.18.bb')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_0.18.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_0.18.bb b/meta-oe/recipes-connectivity/iwd/iwd_0.18.bb
new file mode 100644
index 0000000000..f56c88b821
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iwd/iwd_0.18.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Wireless daemon for Linux"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
+
+inherit autotools pkgconfig systemd
+
+DEPENDS = "ell readline dbus"
+
+SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git"
+SRCREV = "c923448bacf8a855b40017fe53ba2edcd062eec1"
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
+PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
+PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
+
+EXTRA_OECONF += "--enable-external-ell"
+
+do_configure_prepend () {
+ mkdir -p ${S}/build-aux
+}
+
+do_install_append() {
+ mkdir --parents ${D}${docdir}/${BPN}
+ install -m644 ${S}/doc/*.txt ${D}${docdir}/${BPN}
+}
+
+FILES_${PN} += "${datadir}/dbus-1 ${libdir}/modules-load.d"
+
+SYSTEMD_SERVICE_${PN} = "iwd.service ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)}"
+
+RRECOMMENDS_${PN} = "\
+ kernel-module-pkcs7-message \
+ kernel-module-pkcs8-key-parser \
+ kernel-module-x509-key-parser \
+"