aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
index a1c4ff4ad4..07c73c5f76 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
@@ -88,12 +88,11 @@ USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp
GROUPADD_PARAM_${PN} = "-r ftp"
pkg_postinst_${PN}() {
- if [ -n "$D" ]; then
- exit 0
- fi
+ if [ -z "$D" ]; then
if type systemd-tmpfiles >/dev/null; then
- systemd-tmpfiles --create
+ systemd-tmpfiles --create
elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
- ${sysconfdir}/init.d/populate-volatile.sh update
+ ${sysconfdir}/init.d/populate-volatile.sh update
fi
+ fi
}