aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/tcpdump
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/tcpdump')
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpdump/0001-aclocal.m4-Skip-checking-for-pcap-config.patch33
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpdump_4.99.4.bb (renamed from meta-networking/recipes-support/tcpdump/tcpdump_4.99.0.bb)17
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpslice/tcpslice-1.2a3-time.patch75
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpslice/tcpslice-CVS.20010207-bpf.patch15
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpslice_1.2a3.bb36
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpslice_1.7.bb24
6 files changed, 28 insertions, 172 deletions
diff --git a/meta-networking/recipes-support/tcpdump/tcpdump/0001-aclocal.m4-Skip-checking-for-pcap-config.patch b/meta-networking/recipes-support/tcpdump/tcpdump/0001-aclocal.m4-Skip-checking-for-pcap-config.patch
deleted file mode 100644
index bb56c4d4c9..0000000000
--- a/meta-networking/recipes-support/tcpdump/tcpdump/0001-aclocal.m4-Skip-checking-for-pcap-config.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 867bf5c9d0fb64e1b4e64cb13b983674c270a6bf Mon Sep 17 00:00:00 2001
-From: Yi Fan Yu <yifan.yu@windriver.com>
-Date: Fri, 19 Feb 2021 00:52:35 -0500
-Subject: [PATCH] aclocal.m4: Skip checking for pcap-config
-
-Bitbake triggers an configure error
-saying we should look for pkg-config instead.
-
-Upstream-Status: Inappropriate [OE-Specific]
-
-Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com>
----
- aclocal.m4 | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/aclocal.m4 b/aclocal.m4
-index bd4e27a5..136cb8ca 100644
---- a/aclocal.m4
-+++ b/aclocal.m4
-@@ -584,8 +584,8 @@ AC_DEFUN(AC_LBL_LIBPCAP,
- # No pkg-config
- # Look for an installed pcap-config.
- #
-- AC_PATH_TOOL(PCAP_CONFIG, pcap-config)
-- if test -n "$PCAP_CONFIG" ; then
-+ # AC_PATH_TOOL(PCAP_CONFIG, pcap-config)
-+ if false; then
- #
- # Found - use it to get the include flags for
- # libpcap and the flags to link with libpcap.
---
-2.29.2
-
diff --git a/meta-networking/recipes-support/tcpdump/tcpdump_4.99.0.bb b/meta-networking/recipes-support/tcpdump/tcpdump_4.99.4.bb
index 97a9027af4..803a9bb5f5 100644
--- a/meta-networking/recipes-support/tcpdump/tcpdump_4.99.0.bb
+++ b/meta-networking/recipes-support/tcpdump/tcpdump_4.99.4.bb
@@ -24,15 +24,13 @@ SRC_URI = " \
http://www.tcpdump.org/release/${BP}.tar.gz \
file://add-ptest.patch \
file://run-ptest \
- file://0001-aclocal.m4-Skip-checking-for-pcap-config.patch \
"
-SRC_URI[md5sum] = "b10aa2f497def7283bc060f626879ce5"
-SRC_URI[sha256sum] = "8cf2f17a9528774a7b41060323be8b73f76024f7778f59c34efa65d49d80b842"
+SRC_URI[sha256sum] = "0232231bb2f29d6bf2426e70a08a7e0c63a0d59a9b44863b7f5e2357a6e49fea"
-UPSTREAM_CHECK_REGEX = "tcpdump-(?P<pver>\d+(\.(?!99)\d+)+)\.tar"
+UPSTREAM_CHECK_REGEX = "tcpdump-(?P<pver>\d+(\.\d+)+)\.tar"
-inherit autotools-brokensep ptest
+inherit autotools-brokensep pkgconfig ptest
PACKAGECONFIG ?= "openssl"
@@ -42,14 +40,7 @@ PACKAGECONFIG[smi] = "--with-smi,--without-smi,libsmi"
# Note: CVE-2018-10103 (SMB - partially fixed, but SMB printing disabled)
PACKAGECONFIG[smb] = "--enable-smb,--disable-smb"
-EXTRA_AUTORECONF += "-I m4"
-
-do_configure:prepend() {
- mkdir -p ${S}/m4
- if [ -f aclocal.m4 ]; then
- mv aclocal.m4 ${S}/m4
- fi
-}
+EXTRA_AUTORECONF += "--exclude=aclocal"
do_install:append() {
# make install installs an unneeded extra copy of the tcpdump binary
diff --git a/meta-networking/recipes-support/tcpdump/tcpslice/tcpslice-1.2a3-time.patch b/meta-networking/recipes-support/tcpdump/tcpslice/tcpslice-1.2a3-time.patch
deleted file mode 100644
index 386b7f83ac..0000000000
--- a/meta-networking/recipes-support/tcpdump/tcpslice/tcpslice-1.2a3-time.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-Upstream-Status: Pending [from tcpdump-4.1.1-1.fc14.src.rpm]
-
-Signed-off-by: Roy Li <rongqing.li@windriver.com>
-
---- tcpslice-1.2a3.orig/search.c 2000-09-10 10:52:40.000000000 +0200
-+++ tcpslice-1.2a3/search.c 2006-07-28 14:56:55.000000000 +0200
-@@ -53,7 +53,7 @@
- /* Size of a packet header in bytes; easier than typing the sizeof() all
- * the time ...
- */
--#define PACKET_HDR_LEN (sizeof( struct pcap_pkthdr ))
-+#define PACKET_HDR_LEN (sizeof( struct pcap_sf_pkthdr ))
-
- extern int snaplen;
-
-@@ -111,16 +111,24 @@
- static void
- extract_header( pcap_t *p, u_char *buf, struct pcap_pkthdr *hdr )
- {
-- memcpy((char *) hdr, (char *) buf, sizeof(struct pcap_pkthdr));
-+ struct pcap_sf_pkthdr hdri;
-+
-+ memcpy((char *) &hdri, (char *) buf, sizeof(struct pcap_sf_pkthdr));
-
- if ( pcap_is_swapped( p ) )
- {
-- hdr->ts.tv_sec = SWAPLONG(hdr->ts.tv_sec);
-- hdr->ts.tv_usec = SWAPLONG(hdr->ts.tv_usec);
-- hdr->len = SWAPLONG(hdr->len);
-- hdr->caplen = SWAPLONG(hdr->caplen);
-+ hdr->ts.tv_sec = SWAPLONG(hdri.ts.tv_sec);
-+ hdr->ts.tv_usec = SWAPLONG(hdri.ts.tv_usec);
-+ hdr->len = SWAPLONG(hdri.len);
-+ hdr->caplen = SWAPLONG(hdri.caplen);
-+ }
-+ else
-+ {
-+ hdr->ts.tv_sec = hdri.ts.tv_sec;
-+ hdr->ts.tv_usec = hdri.ts.tv_usec;
-+ hdr->len = hdri.len;
-+ hdr->caplen = hdri.caplen;
- }
--
- /*
- * From bpf/libpcap/savefile.c:
- *
---- tcpslice-1.2a3.orig/tcpslice.h 1995-11-02 00:40:53.000000000 +0100
-+++ tcpslice-1.2a3/tcpslice.h 2006-07-28 14:56:55.000000000 +0200
-@@ -20,6 +20,26 @@
- */
-
-
-+#include <time.h>
-+/* #include <net/bpf.h> */
-+
-+/*
-+ * This is a timeval as stored in disk in a dumpfile.
-+ * It has to use the same types everywhere, independent of the actual
-+ * `struct timeval'
-+ */
-+
-+struct pcap_timeval {
-+ bpf_int32 tv_sec; /* seconds */
-+ bpf_int32 tv_usec; /* microseconds */
-+};
-+
-+struct pcap_sf_pkthdr {
-+ struct pcap_timeval ts; /* time stamp */
-+ bpf_u_int32 caplen; /* length of portion present */
-+ bpf_u_int32 len; /* length this packet (off wire) */
-+};
-+
- time_t gwtm2secs( struct tm *tm );
-
- int sf_find_end( struct pcap *p, struct timeval *first_timestamp,
diff --git a/meta-networking/recipes-support/tcpdump/tcpslice/tcpslice-CVS.20010207-bpf.patch b/meta-networking/recipes-support/tcpdump/tcpslice/tcpslice-CVS.20010207-bpf.patch
deleted file mode 100644
index 0a7359311d..0000000000
--- a/meta-networking/recipes-support/tcpdump/tcpslice/tcpslice-CVS.20010207-bpf.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Upstream-Status: Pending [from tcpdump-4.1.1-1.fc14.src.rpm]
-
-Signed-off-by: Roy Li <rongqing.li@windriver.com>
-diff -ur tcpdump-3.8.1/tcpslice/tcpslice.c tcpdump-3.8.1.new/tcpslice/tcpslice.c
---- tcpslice/tcpslice.c 2004-01-15 17:35:53.000000000 +0100
-+++ tcpslice/tcpslice.c 2004-01-15 16:12:57.000000000 +0100
-@@ -35,7 +35,7 @@
- #include <sys/file.h>
- #include <sys/stat.h>
-
--#include <net/bpf.h>
-+/* #include <net/bpf.h> */
-
- #include <ctype.h>
- #ifdef HAVE_FCNTL_H
diff --git a/meta-networking/recipes-support/tcpdump/tcpslice_1.2a3.bb b/meta-networking/recipes-support/tcpdump/tcpslice_1.2a3.bb
deleted file mode 100644
index e65739a5c7..0000000000
--- a/meta-networking/recipes-support/tcpdump/tcpslice_1.2a3.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-SUMMARY = "tcpslice"
-DESCRIPTION = "A tool for extracting parts of a tcpdump packet trace."
-HOMEPAGE = "http://www.tcpdump.org/related.html"
-SECTION = "net"
-
-LICENSE = "BSD-4-Clause"
-LIC_FILES_CHKSUM = "file://tcpslice.c;endline=20;md5=99519e2e5234d1662a4ce16baa62c64e"
-
-SRC_URI = "ftp://ftp.ee.lbl.gov/${BP}.tar.gz \
- file://tcpslice-1.2a3-time.patch \
- file://tcpslice-CVS.20010207-bpf.patch \
- "
-SRC_URI[md5sum] = "e329cbeb7e589f132d92c3447c477190"
-SRC_URI[sha256sum] = "4096e8debc898cfaa16b5306f1c42f8d18b19e30e60da8d4deb781c8f684c840"
-
-inherit autotools-brokensep
-
-DEPENDS += "libpcap"
-
-# We do not want to autoreconf. We must specify srcdir as ".".
-# We have to set the ac_cv_* cache variables as well as pass the normal
-# cross-compilation options to configure!
-#
-do_configure () {
- oe_runconf \
- --srcdir="." \
- ac_cv_build=${BUILD_SYS} \
- ac_cv_host=${HOST_SYS} \
- ac_cv_target=${HOST_SYS}
-}
-
-do_install () {
- mkdir -p ${D}/usr/sbin
- install -c -m 555 tcpslice ${D}/usr/sbin
-}
-
diff --git a/meta-networking/recipes-support/tcpdump/tcpslice_1.7.bb b/meta-networking/recipes-support/tcpdump/tcpslice_1.7.bb
new file mode 100644
index 0000000000..93197dc3bc
--- /dev/null
+++ b/meta-networking/recipes-support/tcpdump/tcpslice_1.7.bb
@@ -0,0 +1,24 @@
+SUMMARY = "tcpslice"
+DESCRIPTION = "A tool for extracting parts of a tcpdump packet trace."
+HOMEPAGE = "http://www.tcpdump.org/related.html"
+SECTION = "net"
+
+LICENSE = "BSD-4-Clause"
+LIC_FILES_CHKSUM = "file://tcpslice.c;endline=20;md5=99519e2e5234d1662a4ce16baa62c64e"
+
+SRC_URI = "http://www.tcpdump.org/release/${BP}.tar.gz \
+ "
+SRC_URI[sha256sum] = "e513f0710c4ab45ec627e5df6f7b80d12e488146e1bd500c92247e20ca608903"
+
+UPSTREAM_CHECK_REGEX = "tcpslice-(?P<pver>\d+(\.\d+)+)\.tar"
+
+inherit autotools-brokensep pkgconfig
+
+DEPENDS = "libpcap"
+
+EXTRA_AUTORECONF += "--exclude=aclocal"
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 tcpslice ${D}${sbindir}
+}