aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/spice/spice_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/spice/spice_git.bb')
-rw-r--r--meta-networking/recipes-support/spice/spice_git.bb32
1 files changed, 17 insertions, 15 deletions
diff --git a/meta-networking/recipes-support/spice/spice_git.bb b/meta-networking/recipes-support/spice/spice_git.bb
index 2039841ddf..dfe4613641 100644
--- a/meta-networking/recipes-support/spice/spice_git.bb
+++ b/meta-networking/recipes-support/spice/spice_git.bb
@@ -25,19 +25,21 @@ SRCREV_spice-protocol = "784407f248e7f99d2bfcc9368f9acd1efb2b9617"
SRCREV_FORMAT = "spice_spice-common_spice-protocol"
-SRC_URI = "git://anongit.freedesktop.org/spice/spice;name=spice \
- git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/spice-common;name=spice-common \
- git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol \
- "
+SRC_URI = " \
+ git://anongit.freedesktop.org/spice/spice;name=spice \
+ git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/spice-common;name=spice-common \
+ git://anongit.freedesktop.org/spice/spice-protocol;destsuffix=git/spice-common/spice-protocol;name=spice-protocol \
+"
SRC_URI += " \
- file://spice-fix-CVE-2013-4282.patch \
- file://configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch \
- file://build-allow-separated-src-and-build-dirs.patch \
- file://0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch \
- file://0001-Use-PRI-macros-in-printf-to-keep-compatibility-betwe.patch \
- file://Fix-build-issues-with-gcc-7.patch \
- "
+ file://spice-fix-CVE-2013-4282.patch \
+ file://configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch \
+ file://build-allow-separated-src-and-build-dirs.patch \
+ file://0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch \
+ file://0001-Use-PRI-macros-in-printf-to-keep-compatibility-betwe.patch \
+ file://Fix-build-issues-with-gcc-7.patch \
+ file://0001-spice-compile-warnings.m4-don-t-define-FORITFY_SOURC.patch \
+"
S = "${WORKDIR}/git"
@@ -66,13 +68,13 @@ FILES_${PN}-protocol += "${includedir}/spice-1"
FILES_${PN}-protocol += "${datadir}/pkgconfig"
do_configure_prepend() {
- mkdir -p ${S}/spice-common/spice-protocol/m4
+ mkdir -p ${S}/spice-common/spice-protocol/m4
}
do_install_append() {
- cd ${B}/spice-common/spice-protocol
- oe_runmake DESTDIR="${D}" install
- cd -
+ cd ${B}/spice-common/spice-protocol
+ oe_runmake DESTDIR="${D}" install
+ cd -
}
COMPATIBLE_HOST = '(x86_64|i.86).*-linux'