aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/spice/spice_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/spice/spice_git.bb')
-rw-r--r--meta-networking/recipes-support/spice/spice_git.bb47
1 files changed, 15 insertions, 32 deletions
diff --git a/meta-networking/recipes-support/spice/spice_git.bb b/meta-networking/recipes-support/spice/spice_git.bb
index 1887a5582f..419316a26e 100644
--- a/meta-networking/recipes-support/spice/spice_git.bb
+++ b/meta-networking/recipes-support/spice/spice_git.bb
@@ -13,53 +13,36 @@ architectures."
LICENSE = "LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
-PV = "0.14.2+git${SRCPV}"
+PV = "0.15.2"
-SRCREV_spice = "7cbd70b931db76c69c89c2d9d5d704f67381a81b"
-SRCREV_spice-common = "4fc4c2db36c7f07b906e9a326a9d3dc0ae6a2671"
+SRCREV = "0c2c1413a8b387ea597a95b6c867470a7c56c8ab"
-SRCREV_FORMAT = "spice_spice-common"
-
-SRC_URI = " \
- git://anongit.freedesktop.org/spice/spice;name=spice;branch=master \
- git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common;branch=master \
- file://0001-Convert-pthread_t-to-be-numeric.patch \
- file://0001-Fix-compile-errors-on-Linux-32bit-system.patch \
- file://0001-configure.ac-explicitly-link-to-jpeg-lib.patch \
-"
+SRC_URI = "gitsm://gitlab.freedesktop.org/spice/spice;branch=master;protocol=https"
S = "${WORKDIR}/git"
-CVE_CHECK_IGNORE += "\
- CVE-2016-0749 \
- CVE-2016-2150 \
- CVE-2018-10893 \
-"
+CVE_STATUS[CVE-2018-10893] = "fixed-version: patched already, caused by inaccurate CPE in the NVD database."
-inherit autotools gettext python3native python3-dir pkgconfig
+inherit meson gettext python3native python3-dir pkgconfig
-DEPENDS += "spice-protocol jpeg pixman alsa-lib glib-2.0 python3-pyparsing-native python3-six-native glib-2.0-native"
+DEPENDS = "spice-protocol jpeg pixman alsa-lib glib-2.0 gdk-pixbuf lz4 orc python3-pyparsing-native python3-six-native glib-2.0-native zlib"
DEPENDS:append:class-nativesdk = " nativesdk-openssl"
export PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3"
-CFLAGS:append = " -Wno-error"
+do_configure:prepend() {
+ echo ${PV} > ${S}/.tarball-version
+}
PACKAGECONFIG:class-native = ""
PACKAGECONFIG:class-nativesdk = ""
-PACKAGECONFIG ?= "sasl"
+PACKAGECONFIG ?= "sasl opus smartcard gstreamer"
-PACKAGECONFIG[celt051] = "--enable-celt051,--disable-celt051,celt051"
-PACKAGECONFIG[smartcard] = "--enable-smartcard,--disable-smartcard,libcacard,"
-PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,"
-PACKAGECONFIG[client] = "--enable-client,--disable-client,,"
-PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,,"
-PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus,"
-PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,,"
-PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama,"
+PACKAGECONFIG[gstreamer] = "-Dgstreamer=1.0,-Dgstreamer=no,gstreamer1.0 gstreamer1.0-plugins-base"
+PACKAGECONFIG[smartcard] = "-Dsmartcard=enabled,-Dsmartcard=disabled,libcacard,libcacard"
+PACKAGECONFIG[sasl] = "-Dsasl=true,-Dsasl=false,cyrus-sasl,"
+PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus,"
-COMPATIBLE_HOST = '(x86_64|i.86).*-linux'
+COMPATIBLE_HOST = '(x86_64|i.86|aarch64).*-linux'
BBCLASSEXTEND = "native nativesdk"
-
-EXTRA_OECONF:append:toolchain-clang = " --disable-werror"