aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/opendataplane/opendataplane_0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/opendataplane/opendataplane_0.2.bb')
-rw-r--r--meta-networking/recipes-support/opendataplane/opendataplane_0.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/opendataplane/opendataplane_0.2.bb b/meta-networking/recipes-support/opendataplane/opendataplane_0.2.bb
new file mode 100644
index 0000000000..6f7f601b10
--- /dev/null
+++ b/meta-networking/recipes-support/opendataplane/opendataplane_0.2.bb
@@ -0,0 +1,25 @@
+require ${BPN}.inc
+
+#odp-0.2 tag
+SRCREV = "6007d8833a6880abedf98f792586c0cfb9f10de0"
+PV = "0.2"
+
+#0.2 still using pure Makefile
+
+#override the Makefile DESTDIR
+export DESTDIR="${D}${exec_prefix}"
+
+do_install () {
+ oe_runmake install
+
+ #move DESTDIR/share/odp/odp_x usr/bin
+ install -d ${D}${bindir}
+ for i in ${DESTDIR}/share/odp/*; do
+ filename=`basename $i`
+ mv ${DESTDIR}/share/odp/${filename} ${D}${bindir}/${filename}
+ done
+ rm -rf ${DESTDIR}/share
+}
+
+#non standard doc install location
+FILES_${PN}-doc += "${exec_prefix}/doc/*"