aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb')
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb21
1 files changed, 17 insertions, 4 deletions
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
index ded6d08a72..1651eb83d0 100644
--- a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
@@ -1,13 +1,18 @@
SUMMARY = "The Linux Kernel Stream Control Transmission Protocol (lksctp) project"
+HOMEPAGE = "http://lksctp.org"
SECTION = "libs"
-LICENSE = "LGPLv2"
+LICENSE = "LGPLv2.1 & GPLv2"
LIC_FILES_CHKSUM = " \
file://COPYING.lib;md5=0a1b79af951c42a9c8573533fbba9a92 \
file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e \
"
-SRC_URI = "${SOURCEFORGE_MIRROR}/lksctp/${BP}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/lksctp/${BP}.tar.gz \
+ file://run-ptest \
+ file://v4test.sh \
+ file://v6test.sh \
+ "
SRC_URI[md5sum] = "708bb0b5a6806ad6e8d13c55b067518e"
SRC_URI[sha256sum] = "0903dd526b7f30a89d5031aa2c82757612becc38ed7bc6e4f972f8deae351f26"
@@ -16,13 +21,21 @@ SRC_URI[sha256sum] = "0903dd526b7f30a89d5031aa2c82757612becc38ed7bc6e4f972f8deae
#| /home/jenkins/oe/world/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.0/ld: error: symbol sctp_connectx has undefined version
#| collect2: error: ld returned 1 exit status
#| make[4]: *** [libsctp.la] Error 1
-PNBLACKLIST[lksctp-tools] ?= "BROKEN: fails to link against sctp_connectx symbol"
+PNBLACKLIST[lksctp-tools] ?= "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', "BROKEN: fails to link against sctp_connectx symbol", '', d)}"
S = "${WORKDIR}/${BP}"
BBCLASSEXTEND = "native"
-inherit autotools pkgconfig binconfig
+inherit autotools pkgconfig binconfig ptest
+
+do_install_ptest () {
+ install -m 0755 ${WORKDIR}/v4test.sh ${D}${PTEST_PATH}
+ install -m 0755 ${WORKDIR}/v6test.sh ${D}${PTEST_PATH}
+ for testcase in `find ${B}/src/apps/.libs ${B}/src/func_tests/.libs -maxdepth 1 -type f -executable`; do
+ install $testcase ${D}${PTEST_PATH}
+ done
+}
SOLIBVERSION="${PV}"
SOLIBMAJORVERSION="1"