aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb')
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
index 799cf8611c..131f1873a2 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
@@ -5,9 +5,10 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://doc/LICENSE;md5=fd0c9adf285a69aa3b4faf34384e1029"
DEPENDS = "curl"
-DEPENDS_class-native = "curl-native"
+DEPENDS:class-native = "curl-native"
-SRC_URI = "git://github.com/jpbarrette/curlpp.git"
+SRC_URI = "git://github.com/jpbarrette/curlpp.git;branch=master;protocol=https \
+ file://0001-curlpp-config.in-Remove-references-to-absolute-build.patch"
SRCREV = "592552a165cc569dac7674cb7fc9de3dc829906f"
@@ -16,3 +17,10 @@ S = "${WORKDIR}/git"
inherit cmake pkgconfig binconfig
BBCLASSEXTEND = "native nativesdk"
+
+do_install:append() {
+ sed -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
+ -i ${D}${libdir}/pkgconfig/*.pc
+}