aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols/zeroconf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-protocols/zeroconf')
-rw-r--r--meta-networking/recipes-protocols/zeroconf/zeroconf/makefile-add-ldflags.patch19
-rw-r--r--meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb1
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/zeroconf/zeroconf/makefile-add-ldflags.patch b/meta-networking/recipes-protocols/zeroconf/zeroconf/makefile-add-ldflags.patch
new file mode 100644
index 0000000000..c5a4414db8
--- /dev/null
+++ b/meta-networking/recipes-protocols/zeroconf/zeroconf/makefile-add-ldflags.patch
@@ -0,0 +1,19 @@
+Add LDFLAGS variable to Makefile, make sure the extra linker flags can be passed.
+
+Upstream-Status: Pending
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+
+diff --git a/Makefile b/Makefile
+index 77f3364..c98083f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,7 +18,7 @@ clean:
+
+ zeroconf: zeroconf.o delay.o
+ $(Q)echo "Creating $@"
+- $(Q)$(CC) $(CFLAGS) -o $@ $^ $(LIBS)
++ $(Q)$(CC) $(CFLAGS) ${LDFLAGS} -o $@ $^ $(LIBS)
+
+
+ # Automatic dependency generation
diff --git a/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb b/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb
index 9307263c7b..13f9b9b9a3 100644
--- a/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb
+++ b/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb
@@ -18,6 +18,7 @@ PR = "r1"
SRC_URI = "http://www.progsoc.org/~wildfire/zeroconf/download/${BPN}-${PV}.tar.gz \
file://compilefix.patch \
+ file://makefile-add-ldflags.patch \
file://zeroconf-default \
file://debian-zeroconf"