aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-filter')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
index 2e49dab332..e9b726c5fb 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
@@ -27,6 +27,19 @@ S = "${WORKDIR}/ebtables-v${PV}"
inherit update-rc.d systemd
+python __anonymous () {
+ import re
+
+ karch = d.getVar('KARCH', True)
+ multilib = d.getVar('MLPREFIX', True)
+
+ if multilib and karch == 'powerpc64':
+ searchstr = "lib.?32"
+ reg = re.compile(searchstr)
+ if reg.search(multilib):
+ d.appendVar('CFLAGS' ,' -DKERNEL_64_USERSPACE_32 -DEBT_MIN_ALIGN=8')
+}
+
EXTRA_OEMAKE = " \
BINDIR=${base_sbindir} \
MANDIR=${mandir} \