aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-do-not-check-for-modprobe.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-do-not-check-for-modprobe.patch')
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-do-not-check-for-modprobe.patch46
1 files changed, 30 insertions, 16 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-do-not-check-for-modprobe.patch b/meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-do-not-check-for-modprobe.patch
index af5be6a830..1d5c3e1eeb 100644
--- a/meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-do-not-check-for-modprobe.patch
+++ b/meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-do-not-check-for-modprobe.patch
@@ -1,3 +1,8 @@
+From 2cbc576ea1fbd1cbf4579d64b30e41d762084e7f Mon Sep 17 00:00:00 2001
+From: "yanjun.zhu" <yanjun.zhu@windriver.com>
+Date: Tue, 15 Jan 2013 12:45:44 +0800
+Subject: [PATCH] autofs: do not check for modprobe
+
Description: Loading autofs module is #ifdef'ed in the source, so
there is no need to check for /proc (which is only used
to load module) or modprobe. Both modprobe and /proc
@@ -7,9 +12,16 @@ Description: Loading autofs module is #ifdef'ed in the source, so
Upstream-Status: Backport [1]
[1] http://www.spinics.net/lists/autofs/msg00139.html
-diff -urpN a/configure.in b/configure.in
---- a/configure.in 2013-01-15 11:30:22.000000000 +0800
-+++ b/configure.in 2013-01-15 11:31:45.000000000 +0800
+---
+ configure.in | 6 ------
+ daemon/module.c | 3 +++
+ include/automount.h | 11 +++--------
+ 3 files changed, 6 insertions(+), 14 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 44a1c8b..b226236 100644
+--- a/configure.in
++++ b/configure.in
@@ -34,11 +34,6 @@ AC_MSG_CHECKING([for binaries in])
AC_MSG_RESULT([$searchpath])
@@ -22,7 +34,7 @@ diff -urpN a/configure.in b/configure.in
# Location of init.d directory?
#
AF_INIT_D()
-@@ -142,7 +137,6 @@ AF_PATH_INCLUDE(UMOUNT, umount, /bin/umo
+@@ -142,7 +137,6 @@ AF_PATH_INCLUDE(UMOUNT, umount, /bin/umount, $searchpath)
AF_PATH_INCLUDE(E2FSCK, fsck.ext2 e2fsck, , $searchpath)
AF_PATH_INCLUDE(E3FSCK, fsck.ext3 e3fsck, , $searchpath)
AF_PATH_INCLUDE(E4FSCK, fsck.ext4 e4fsck, , $searchpath)
@@ -30,30 +42,32 @@ diff -urpN a/configure.in b/configure.in
AF_CHECK_PROG(LEX, flex lex, , $searchpath)
AF_CHECK_PROG(YACC, bison, , $searchpath)
-diff -urpN a/daemon/module.c b/daemon/module.c
---- a/daemon/module.c 2013-01-15 11:30:49.000000000 +0800
-+++ b/daemon/module.c 2013-01-15 11:32:00.000000000 +0800
-@@ -18,6 +18,8 @@
- #include <stdlib.h>
+diff --git a/daemon/module.c b/daemon/module.c
+index bed8f7a..e41a98e 100644
+--- a/daemon/module.c
++++ b/daemon/module.c
+@@ -19,6 +19,8 @@
#include "automount.h"
+ #include "nsswitch.h"
+#if 0
+/* see comment in daemon/automount.c around load_autofs4_module() call */
int load_autofs4_module(void)
{
FILE *fp;
-@@ -52,6 +54,7 @@ int load_autofs4_module(void)
+@@ -53,6 +55,7 @@ int load_autofs4_module(void)
return 1;
}
+#endif
- struct lookup_mod *open_lookup(const char *name, const char *err_prefix,
- const char *mapfmt, int argc, const char *const *argv)
-diff -urpN a/include/automount.h b/include/automount.h
---- a/include/automount.h 2013-01-15 11:31:10.000000000 +0800
-+++ b/include/automount.h 2013-01-15 11:32:06.000000000 +0800
-@@ -50,16 +50,11 @@
+ int open_lookup(const char *name, const char *err_prefix, const char *mapfmt,
+ int argc, const char *const *argv, struct lookup_mod **lookup)
+diff --git a/include/automount.h b/include/automount.h
+index c0f5fbf..cc336ad 100644
+--- a/include/automount.h
++++ b/include/automount.h
+@@ -51,16 +51,11 @@
#error Failed to locate umount(8)!
#endif