aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/files/1571.patch2
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch14
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/mosquitto_2.0.7.bb (renamed from meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.12.bb)18
3 files changed, 11 insertions, 23 deletions
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/1571.patch b/meta-networking/recipes-connectivity/mosquitto/files/1571.patch
index 93ff6bcfa6..37560f30c8 100644
--- a/meta-networking/recipes-connectivity/mosquitto/files/1571.patch
+++ b/meta-networking/recipes-connectivity/mosquitto/files/1571.patch
@@ -11,7 +11,7 @@ Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
-@@ -89,6 +89,8 @@
+@@ -94,6 +94,8 @@
OUTPUT_NAME mosquitto
VERSION ${VERSION}
SOVERSION 1
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch b/meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch
deleted file mode 100644
index 1397fc6a24..0000000000
--- a/meta-networking/recipes-connectivity/mosquitto/files/install-protocol.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Description: Also install mqtt_protocol.h, as is done in Makefile
-Author: Gianfranco Costamagna <locutusofborg@debian.org>
-Bug-Debian: https://bugs.debian.org/951116
-Forwarded: https://github.com/eclipse/mosquitto/pull/1599
-Last-Update: 2020-02-15
-
---- a/lib/CMakeLists.txt
-+++ b/lib/CMakeLists.txt
-@@ -114,4 +114,4 @@
- install(TARGETS libmosquitto_static ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}")
- endif (WITH_STATIC_LIBRARIES)
-
--install(FILES mosquitto.h DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}")
-+install(FILES mqtt_protocol.h mosquitto.h DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}")
diff --git a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.12.bb b/meta-networking/recipes-connectivity/mosquitto/mosquitto_2.0.7.bb
index 36bfe099f3..06220327e3 100644
--- a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.6.12.bb
+++ b/meta-networking/recipes-connectivity/mosquitto/mosquitto_2.0.7.bb
@@ -6,22 +6,21 @@ provides a lightweight method of carrying out messaging using a \
publish/subscribe model. "
HOMEPAGE = "http://mosquitto.org/"
SECTION = "console/network"
-LICENSE = "EPL-1.0 | EDL-1.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=62ddc846179e908dc0c8efec4a42ef20 \
+LICENSE = "EPL-2.0 | EDL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ca9a8f366c6babf593e374d0d7d58749 \
file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \
- file://epl-v10;md5=8d383c379e91d20ba18a52c3e7d3a979 \
- file://notice.html;md5=a00d6f9ab542be7babc2d8b80d5d2a4c \
+ file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \
+ file://notice.html;md5=541f8f37af492858dab8d2c1b69ede69 \
"
-DEPENDS = "uthash"
+DEPENDS = "uthash cjson dlt-daemon"
SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \
file://mosquitto.init \
file://1571.patch \
- file://install-protocol.patch \
"
-SRC_URI[md5sum] = "beb8d76d6e45f1e66d711006082a631f"
-SRC_URI[sha256sum] = "548d73d19fb787dd0530334e398fd256ef3a581181678488a741a995c4f007fb"
+SRC_URI[md5sum] = "56de4e27533ab53697245809feea95bf"
+SRC_URI[sha256sum] = "a98054f0b8161588975ef24e1d467550d3935f4c16ccee63ecb623248a28356e"
inherit systemd update-rc.d useradd cmake
@@ -29,6 +28,7 @@ PACKAGECONFIG ??= "ssl dlt websockets \
${@bb.utils.filter('DISTRO_FEATURES','systemd', d)} \
"
+PACKAGECONFIG[manpages] = "-DDOCUMENTATION=ON,-DDOCUMENTATION=OFF,libxslt-native docbook-xsl-stylesheets-native"
PACKAGECONFIG[dns-srv] = "-DWITH_SRV=ON,-DWITH_SRV=OFF,c-ares"
PACKAGECONFIG[ssl] = "-DWITH_TLS=ON -DWITH_TLS_PSK=ON -DWITH_EC=ON,-DWITH_TLS=OFF -DWITH_TLS_PSK=OFF -DWITH_EC=OFF,openssl"
PACKAGECONFIG[systemd] = "-DWITH_SYSTEMD=ON,-DWITH_SYSTEMD=OFF,systemd"
@@ -59,6 +59,8 @@ PACKAGE_BEFORE_PN = "${PN}-examples"
FILES_${PN} = "${sbindir}/mosquitto \
${bindir}/mosquitto_passwd \
+ ${bindir}/mosquitto_ctrl \
+ ${libdir}/mosquitto_dynamic_security.so \
${sysconfdir}/mosquitto \
${sysconfdir}/init.d \
${systemd_unitdir}/system/mosquitto.service \