aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/kea
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/kea')
-rw-r--r--meta-networking/recipes-connectivity/kea/kea_1.5.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/kea/kea_1.5.0.bb b/meta-networking/recipes-connectivity/kea/kea_1.5.0.bb
index 9210ac1bc1..fb166df607 100644
--- a/meta-networking/recipes-connectivity/kea/kea_1.5.0.bb
+++ b/meta-networking/recipes-connectivity/kea/kea_1.5.0.bb
@@ -23,6 +23,16 @@ inherit autotools systemd
SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
SYSTEMD_AUTO_ENABLE = "disable"
+DEBUG_OPTIMIZATION_remove_mips = " -Og"
+DEBUG_OPTIMIZATION_append_mips = " -O"
+BUILD_OPTIMIZATION_remove_mips = " -Og"
+BUILD_OPTIMIZATION_append_mips = " -O"
+
+DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
+DEBUG_OPTIMIZATION_append_mipsel = " -O"
+BUILD_OPTIMIZATION_remove_mipsel = " -Og"
+BUILD_OPTIMIZATION_append_mipsel = " -O"
+
do_configure_prepend_class-target() {
mkdir -p ${B}/src/lib/log/compiler/
ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler