aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp/0001-Fix-build-with-hardened-security-flags.patch61
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.4.bb8
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.6.bb10
3 files changed, 71 insertions, 8 deletions
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp/0001-Fix-build-with-hardened-security-flags.patch b/meta-multimedia/recipes-connectivity/gupnp/gupnp/0001-Fix-build-with-hardened-security-flags.patch
new file mode 100644
index 0000000000..ef0c945d0b
--- /dev/null
+++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp/0001-Fix-build-with-hardened-security-flags.patch
@@ -0,0 +1,61 @@
+From 6eba07bd195e0a1199a0fc62d7cc31ec376bc3dd Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Mon, 31 May 2021 17:44:29 +0200
+Subject: [PATCH] Fix build with hardened security flags
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+| ../gupnp-1.2.6/examples/get-volume.c: In function 'on_introspection':
+| ../gupnp-1.2.6/examples/get-volume.c:53:17: error: format not a string literal and no format arguments [-Werror=format-security]
+| 53 | g_critical (error->message);
+| | ^~~~~~~~~~
+| ../gupnp-1.2.6/examples/get-volume.c:114:17: error: format not a string literal and no format arguments [-Werror=format-security]
+| 114 | g_critical (error->message);
+| | ^~~~~~~~~~
+| ../gupnp-1.2.6/examples/get-volume.c: In function 'main':
+| ../gupnp-1.2.6/examples/get-volume.c:150:17: error: format not a string literal and no format arguments [-Werror=format-security]
+| 150 | g_error (error->message);
+| | ^~~~~~~
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+
+Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/gupnp/-/merge_requests/17]
+---
+ examples/get-volume.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/examples/get-volume.c b/examples/get-volume.c
+index 4601014..923581c 100644
+--- a/examples/get-volume.c
++++ b/examples/get-volume.c
+@@ -50,7 +50,7 @@ on_introspection (GObject *object, GAsyncResult *res, gpointer user_data)
+ &error);
+
+ if (error != NULL) {
+- g_critical (error->message);
++ g_critical ("%s", error->message);
+ g_clear_error (&error);
+ }
+
+@@ -111,7 +111,7 @@ on_introspection (GObject *object, GAsyncResult *res, gpointer user_data)
+ g_list_free (out_names);
+
+ if (error != NULL) {
+- g_critical (error->message);
++ g_critical ("%s", error->message);
+ g_clear_error (&error);
+ } else {
+ g_print ("Current volume: %s\n",
+@@ -147,7 +147,7 @@ int main(int argc, char *argv[])
+ GUPnPContext *context = gupnp_context_new ("wlp3s0", 0, &error);
+
+ if (error != NULL) {
+- g_error (error->message);
++ g_error ("%s", error->message);
+ }
+
+ GUPnPControlPoint *cp = gupnp_control_point_new (context, CONTENT_DIR);
+--
+2.31.1
+
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.4.bb b/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.4.bb
deleted file mode 100644
index c7b330fa00..0000000000
--- a/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.4.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require gupnp.inc
-
-SRC_URI = "${GNOME_MIRROR}/${BPN}/1.2/${BPN}-${PV}.tar.xz"
-SRC_URI[md5sum] = "7c9c7cd80e36d9fb1e5b0267571fc17d"
-SRC_URI[sha256sum] = "f7a0307ea51f5e44d1b832f493dd9045444a3a4e211ef85dfd9aa5dd6eaea7d1"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
- file://libgupnp/gupnp.h;beginline=1;endline=20;md5=d78a69d9b6e63ee2dc72e7b674d97520"
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.6.bb b/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.6.bb
new file mode 100644
index 0000000000..294c361db5
--- /dev/null
+++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp_1.2.6.bb
@@ -0,0 +1,10 @@
+require gupnp.inc
+
+SRC_URI = " \
+ ${GNOME_MIRROR}/${BPN}/1.2/${BPN}-${PV}.tar.xz \
+ file://0001-Fix-build-with-hardened-security-flags.patch \
+"
+SRC_URI[sha256sum] = "00b20f1e478a72deac92c34723693a2ac55789ed1e4bb4eed99eb4d62092aafd"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
+ file://libgupnp/gupnp.h;beginline=1;endline=20;md5=d78a69d9b6e63ee2dc72e7b674d97520"