aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb')
-rw-r--r--meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb b/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
new file mode 100644
index 0000000000..7441716635
--- /dev/null
+++ b/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
@@ -0,0 +1,20 @@
+# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library"
+HOMEPAGE = "https://github.com/graeme-hill/crossguid"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68"
+DEPENDS += "util-linux"
+
+SRCREV = "5b45cdd9a56ca9da35ee0f8845cb4e2603d245dc"
+SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+do_install() {
+ install -D -m 0644 ${B}/libxg.a ${D}${libdir}/libxg.a
+ install -D -m 0644 ${S}/Guid.hpp ${D}${includedir}/Guid.hpp
+}