aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch')
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch32
1 files changed, 22 insertions, 10 deletions
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
index 44612275c1..cc73bdb1d9 100644
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
@@ -10,28 +10,40 @@ Upstream-Status: Inappropriate [embedded specific]
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
---
- src/CMakeLists.txt | 11 -----------
- 1 file changed, 11 deletions(-)
+ src/CMakeLists.txt | 23 +----------------------
+ 1 file changed, 1 insertion(+), 22 deletions(-)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index a0ba53d1..1c626717 100644
+index 356bb734..58ff7635 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -359,14 +359,3 @@ else ( MACOSX_FRAMEWORK )
- )
+@@ -399,25 +399,4 @@ else ( MACOSX_FRAMEWORK )
install ( FILES ${public_main_HEADER} DESTINATION ${INCLUDE_INSTALL_DIR} )
endif ( MACOSX_FRAMEWORK )
--
+
-# ******* Auto Generated Lookup Tables ******
-
-include(ExternalProject)
+-
+-set (GENTAB_SDIR ${CMAKE_CURRENT_SOURCE_DIR}/gentables)
+-set (GENTAB_BDIR ${CMAKE_CURRENT_BINARY_DIR}/gentables)
+-
+-# Use external project to ensure that cmake uses the host compiler when building make_tables.exe
+-# To fix cross-compiling fluidsynth from Win32 to ARM (using vcpkg), we need to pass the current generator
+-# on to the external project, otherwise (for some unknown reason) the target compiler will be used rather
+-# than the host compiler.
-ExternalProject_Add(gentables
- DOWNLOAD_COMMAND ""
-- SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/gentables
-- BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/gentables
-- INSTALL_COMMAND ${CMAKE_CURRENT_BINARY_DIR}/gentables/make_tables.exe "${CMAKE_BINARY_DIR}/"
+- SOURCE_DIR ${GENTAB_SDIR}
+- BINARY_DIR ${GENTAB_BDIR}
+- CONFIGURE_COMMAND
+- "${CMAKE_COMMAND}" -DCMAKE_VERBOSE_MAKEFILE=${CMAKE_VERBOSE_MAKEFILE} -G "${CMAKE_GENERATOR}" -B "${GENTAB_BDIR}" "${GENTAB_SDIR}"
+- BUILD_COMMAND
+- "${CMAKE_COMMAND}" --build "${GENTAB_BDIR}"
+- INSTALL_COMMAND ${GENTAB_BDIR}/make_tables.exe "${CMAKE_BINARY_DIR}/"
-)
-add_dependencies(libfluidsynth-OBJ gentables)
++
--
-2.14.5
+2.21.1