aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb')
-rw-r--r--meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb b/meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb
index 0e93790855..5a998248c8 100644
--- a/meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb
+++ b/meta-initramfs/recipes-devtools/grubby/grubby_8.40.bb
@@ -9,11 +9,14 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
DEPENDS = "popt util-linux"
+DEPENDS_append_libc-musl = " libexecinfo"
SRC_URI = "https://github.com/rhinstaller/${BPN}/archive/${PV}-1.tar.gz;downloadfilename=${BPN}-${PV}-1.tar.gz \
file://grubby-rename-grub2-editenv-to-grub-editenv.patch \
file://run-ptest \
-"
+ file://0001-Add-another-variable-LIBS-to-provides-libraries-from.patch \
+ file://0002-include-paths.h-for-_PATH_MOUNTED.patch \
+ "
SRC_URI[md5sum] = "1005907b275d6d93368d045274537d86"
SRC_URI[sha256sum] = "85f1c678484f74c8978e8643451594967defce463a86c35cb1ee56d12767a9df"
@@ -24,8 +27,10 @@ RDEPENDS_${PN} += "dracut"
inherit autotools-brokensep ptest
-EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}'"
+EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}' LIBS='${LIBS}'"
+LIBS_libc-musl = "-lexecinfo"
+LIBS ?= ""
do_install_ptest() {
install -d ${D}${PTEST_PATH}
cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH}