aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/yelp/yelp_40.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/yelp/yelp_40.2.bb')
-rw-r--r--meta-gnome/recipes-gnome/yelp/yelp_40.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/yelp/yelp_40.2.bb b/meta-gnome/recipes-gnome/yelp/yelp_40.2.bb
new file mode 100644
index 0000000000..f62f8b1bd6
--- /dev/null
+++ b/meta-gnome/recipes-gnome/yelp/yelp_40.2.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Help browser for the GNOME desktop"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=6e1b9cb787e76d7e6946887a65caa754 \
+"
+
+inherit gnomebase itstool autotools-brokensep gsettings gettext gtk-doc features_check mime-xdg
+
+# for webkitgtk
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI[archive.sha256sum] = "8aaaaf753ef4d97526f6a5308f1faee4aa627c4451ec92698a12e528535b5a1c"
+
+DEPENDS += " \
+ libxml2-native \
+ glib-2.0-native \
+ gtk+3 \
+ appstream-glib \
+ libxslt \
+ sqlite3 \
+ webkitgtk \
+ yelp-xsl \
+"
+
+do_configure_prepend() {
+ export ITSTOOL=${STAGING_BINDIR_NATIVE}/itstool
+}
+
+FILES_${PN} += " \
+ ${datadir}/metainfo \
+ ${datadir}/yelp-xsl \
+"
+
+RDEPENDS_${PN} += "yelp-xsl"