aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_40.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_40.1.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_40.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_40.1.bb b/meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_40.1.bb
new file mode 100644
index 0000000000..5e6982714b
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-calculator/gnome-calculator_40.1.bb
@@ -0,0 +1,36 @@
+SUMMARY = "GNOME calculator"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SECTION = "x11/gnome"
+
+DEPENDS = " \
+ yelp-tools-native \
+ gtk+3 \
+ libsoup-2.4 \
+ libgee \
+ libmpc \
+ gtksourceview4 \
+ libhandy \
+"
+
+GIR_MESON_OPTION = 'disable-introspection'
+GIR_MESON_ENABLE_FLAG = 'false'
+GIR_MESON_DISABLE_FLAG = 'true'
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase gobject-introspection gnome-help vala gtk-icon-cache gettext features_check upstream-version-is-even
+
+def gnome_verdir(v):
+ return oe.utils.trim_version(v, 1)
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI[archive.sha256sum] = "7fe6c561f7b1f485ac106219772e45cc135c983bfa4278dd2d3fd83b57ff6af6"
+
+FILES_${PN} += " \
+ ${datadir}/dbus-1 \
+ ${datadir}/metainfo \
+ ${datadir}/gnome-shell \
+"