aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gjs/gjs/0001-meson-Disable-runtime-checks.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gjs/gjs/0001-meson-Disable-runtime-checks.patch')
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs/0001-meson-Disable-runtime-checks.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gjs/gjs/0001-meson-Disable-runtime-checks.patch b/meta-gnome/recipes-gnome/gjs/gjs/0001-meson-Disable-runtime-checks.patch
new file mode 100644
index 0000000000..da5a990326
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gjs/gjs/0001-meson-Disable-runtime-checks.patch
@@ -0,0 +1,48 @@
+From 399ad6ab6d5234199e17df2a16509549943646ce Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 20 Oct 2021 20:31:55 -0700
+Subject: [PATCH] meson: Disable runtime checks
+
+Wont work in cross compile case
+
+Upstream-Status: Inappropriate [Cross-compile specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ meson.build | 21 ---------------------
+ 1 file changed, 21 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index b8112c16..37c6fdd4 100644
+--- a/meson.build
++++ b/meson.build
+@@ -252,27 +252,6 @@ release builds of SpiderMonkey. Try configuring SpiderMonkey with
+ --disable-debug.''')
+ endif
+
+-# Check if a minimal SpiderMonkey program compiles, links, and runs. If not,
+-# it's most likely the case that SpiderMonkey was configured incorrectly, for
+-# example by building mozglue as a shared library.
+-minimal_program = cxx.run('''
+-#include <js/Initialization.h>
+-int main(void) {
+- if (!JS_Init()) return 1;
+- JS_ShutDown();
+- return 0;
+-}
+-''',
+- args: debug_arg, dependencies: spidermonkey,
+- name: 'SpiderMonkey sanity check')
+-
+-if not minimal_program.compiled() or minimal_program.returncode() != 0
+- error('''A minimal SpiderMonkey program
+-could not be compiled, linked, or run. Most likely you should build it with a
+-different configuration. Check the recommended configuration:
+-https://github.com/spidermonkey-embedders/spidermonkey-embedding-examples/blob/esr91/docs/Building%20SpiderMonkey.md''')
+-endif
+-
+ have_printf_alternative_int = cc.compiles('''
+ #include <stdio.h>
+ int main(void) {
+--
+2.33.1
+