aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb34
1 files changed, 17 insertions, 17 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
index 6e1dc4ef09..75c10aeb06 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
@@ -102,21 +102,21 @@ FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
PACKAGES_DYNAMIC = "${PN}-meta ${PN}-plugin-*"
python populate_packages_prepend () {
- abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
- do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
-
- metapkg = "abiword-meta"
- bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
- bb.data.setVar('FILES_' + metapkg, "", d)
- blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
- metapkg_rdepends = []
- packages = bb.data.getVar('PACKAGES', d, 1).split()
- for pkg in packages[1:]:
- if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
- print "Modifying ", pkg
- metapkg_rdepends.append(pkg)
- bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
- bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d)
- packages.append(metapkg)
- bb.data.setVar('PACKAGES', ' '.join(packages), d)
+ abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
+ do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+
+ metapkg = "abiword-meta"
+ bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
+ bb.data.setVar('FILES_' + metapkg, "", d)
+ blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
+ metapkg_rdepends = []
+ packages = bb.data.getVar('PACKAGES', d, 1).split()
+ for pkg in packages[1:]:
+ if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
+ print "Modifying ", pkg
+ metapkg_rdepends.append(pkg)
+ bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
+ bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d)
+ packages.append(metapkg)
+ bb.data.setVar('PACKAGES', ' '.join(packages), d)
}