aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-utils')
-rw-r--r--meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb20
1 files changed, 14 insertions, 6 deletions
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb b/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb
index 33d441e41e..711637a70d 100644
--- a/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb
+++ b/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb
@@ -16,6 +16,7 @@ SRCREV_unionmount = "e3825b16b46f4c4574a1a69909944c059835f914"
S = "${WORKDIR}/git"
+# brokensep because m4/package_globals.m4 calls ". ./VERSION" (and that's not the only issue)
inherit autotools-brokensep useradd
DEPENDS += "xfsprogs acl"
@@ -44,15 +45,22 @@ USERADD_PARAM:${PN} = "-U -m fsgqa; -N 123456-fsgqa; -N fsgqa2"
EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root"
TARGET_CC_ARCH:append:libc-musl = " -D_LARGEFILE64_SOURCE"
-# install-sh script in the project is outdated
-# we use the one from the latest libtool to solve installation issues
-# It looks like the upstream is not interested in having it fixed :(
-# https://www.spinics.net/lists/fstests/msg16981.html
+
do_configure:prepend() {
- cp ${STAGING_DIR_NATIVE}${datadir}/libtool/build-aux/install-sh ${B}
+ # this is done by Makefile configure target, but we don't call it in do_configure
+ cp -a ${S}/include/install-sh .
}
-do_install:append() {
+# Not sure if this is needed, but with old install-sh it was sometimes failing with:
+# cp: cannot stat 'group.list': No such file or directory
+# http://errors.yoctoproject.org/Errors/Details/752404/
+# PARALLEL_MAKEINST = "-j1"
+
+do_install:prepend() {
+ # otherwise install-sh duplicates DESTDIR prefix
+ export DIST_ROOT="/" DIST_MANIFEST="" DESTDIR="${D}"
+ oe_runmake install
+
unionmount_target_dir=${D}/usr/xfstests/unionmount-testsuite
install -d ${D}/usr/xfstests/unionmount-testsuite/tests
install -D ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests