aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/e17
diff options
context:
space:
mode:
Diffstat (limited to 'meta-efl/recipes-efl/e17')
-rw-r--r--meta-efl/recipes-efl/e17/e-tasks_git.bb20
-rw-r--r--meta-efl/recipes-efl/e17/e-wm-theme-b-and-w_svn.bb10
-rw-r--r--meta-efl/recipes-efl/e17/e-wm.inc160
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_0.17.2.1.bb6
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_svn.bb6
-rw-r--r--meta-efl/recipes-efl/e17/elmdentica_svn.bb2
-rw-r--r--meta-efl/recipes-efl/e17/enjoy_svn.bb10
-rw-r--r--meta-efl/recipes-efl/e17/eve_svn.bb6
-rw-r--r--meta-efl/recipes-efl/e17/exquisite-theme-illume.bb2
-rw-r--r--meta-efl/recipes-efl/e17/exquisite_svn.bb16
-rw-r--r--meta-efl/recipes-efl/e17/terminology.inc4
-rw-r--r--meta-efl/recipes-efl/e17/terminology_0.3.0.bb2
12 files changed, 122 insertions, 122 deletions
diff --git a/meta-efl/recipes-efl/e17/e-tasks_git.bb b/meta-efl/recipes-efl/e17/e-tasks_git.bb
index dea6f03a73..29dec4f9f4 100644
--- a/meta-efl/recipes-efl/e17/e-tasks_git.bb
+++ b/meta-efl/recipes-efl/e17/e-tasks_git.bb
@@ -17,16 +17,16 @@ SRC_URI = "git://github.com/shr-project/e-tasks.git;protocol=git;branch=master \
S = "${WORKDIR}/git"
do_install_append() {
- install -d "${D}/${datadir}/pixmaps"
- install -m 0644 "${S}/resources/e-tasks.png" "${D}/${datadir}/pixmaps"
- install -d "${D}/${datadir}/applications"
- install -m 0644 "${S}/resources/e-tasks.desktop" "${D}/${datadir}/applications"
- install -d "${D}/${datadir}/e-tasks"
- for ico in "${S}/resources/"*.png; do
- if [ "$(basename $ico)" != "e-tasks.png" ]; then
- install -m 0644 $ico "${D}/${datadir}/e-tasks"
- fi
- done
+ install -d "${D}/${datadir}/pixmaps"
+ install -m 0644 "${S}/resources/e-tasks.png" "${D}/${datadir}/pixmaps"
+ install -d "${D}/${datadir}/applications"
+ install -m 0644 "${S}/resources/e-tasks.desktop" "${D}/${datadir}/applications"
+ install -d "${D}/${datadir}/e-tasks"
+ for ico in "${S}/resources/"*.png; do
+ if [ "$(basename $ico)" != "e-tasks.png" ]; then
+ install -m 0644 $ico "${D}/${datadir}/e-tasks"
+ fi
+ done
}
FILES_${PN} += "/usr/share/e-tasks/* /usr/share/applications/* /usr/share/pixmaps/*"
diff --git a/meta-efl/recipes-efl/e17/e-wm-theme-b-and-w_svn.bb b/meta-efl/recipes-efl/e17/e-wm-theme-b-and-w_svn.bb
index f826e10697..af32a355a4 100644
--- a/meta-efl/recipes-efl/e17/e-wm-theme-b-and-w_svn.bb
+++ b/meta-efl/recipes-efl/e17/e-wm-theme-b-and-w_svn.bb
@@ -18,14 +18,14 @@ SRC_URI = "${E_SVN}/trunk/THEMES;module=${SRCNAME};protocol=http"
S = "${WORKDIR}/${SRCNAME}/e"
do_compile() {
- # unfortunately hardcoded edje_cc in Makefile
- sed -i "s#\tedje_cc#\t${STAGING_BINDIR_NATIVE}/edje_cc#g" Makefile
- make
+ # unfortunately hardcoded edje_cc in Makefile
+ sed -i "s#\tedje_cc#\t${STAGING_BINDIR_NATIVE}/edje_cc#g" Makefile
+ make
}
do_install() {
- install -d ${D}${datadir}/enlightenment/data/themes/
- install -m 0644 ${S}/b_and_w.edj ${D}${datadir}/enlightenment/data/themes/
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/b_and_w.edj ${D}${datadir}/enlightenment/data/themes/
}
FILES_${PN} = "${datadir}/enlightenment/data/themes/"
diff --git a/meta-efl/recipes-efl/e17/e-wm.inc b/meta-efl/recipes-efl/e17/e-wm.inc
index 61c21d4ab2..78fbd9544d 100644
--- a/meta-efl/recipes-efl/e17/e-wm.inc
+++ b/meta-efl/recipes-efl/e17/e-wm.inc
@@ -9,11 +9,11 @@ inherit e update-alternatives gettext
S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = "\
- --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
- --with-eet-eet=${STAGING_BINDIR_NATIVE}/eet \
- --x-includes=${STAGING_INCDIR}/X11 \
- --x-libraries=${STAGING_LIBDIR} \
- --enable-simple-x11 \
+ --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+ --with-eet-eet=${STAGING_BINDIR_NATIVE}/eet \
+ --x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR} \
+ --enable-simple-x11 \
"
do_configure_prepend() {
@@ -52,16 +52,16 @@ do_install_append() {
}
RDEPENDS_${PN} += "\
- shared-mime-info \
- mime-support \
- setxkbmap \
- edje-utils \
- ${PN}-utils \
- dbus-x11 \
- evas-loader-png \
- evas-loader-jpeg \
- evas-loader-gif \
- evas-generic-loader-svg \
+ shared-mime-info \
+ mime-support \
+ setxkbmap \
+ edje-utils \
+ ${PN}-utils \
+ dbus-x11 \
+ evas-loader-png \
+ evas-loader-jpeg \
+ evas-loader-gif \
+ evas-generic-loader-svg \
"
# Uclibc build don't have 'glibc-utils'
@@ -75,57 +75,57 @@ RCONFLICTS_${PN}-config-mobile = "${PN}-config-illume2"
RPROVIDES_${PN}-config-mobile = "${PN}-config-illume2"
PACKAGES =+ "\
- ${PN}-config-default \
- ${PN}-config-mobile \
- ${PN}-config-minimalist \
- ${PN}-config-netbook \
- ${PN}-config-scaleable \
- ${PN}-config-standard \
- ${PN}-theme-default \
- ${PN}-background-dark-gradient \
- ${PN}-background-light-gradient \
- ${PN}-backgrounds \
- ${PN}-images \
- ${PN}-icons \
- ${PN}-other \
- ${PN}-input-methods \
- ${PN}-sysactions \
- ${PN}-utils \
- ${PN}-menu \
- efm-desktop-icon \
- illume-keyboard-default-alpha \
- illume-keyboard-default-numeric \
- illume-keyboard-default-terminal \
+ ${PN}-config-default \
+ ${PN}-config-mobile \
+ ${PN}-config-minimalist \
+ ${PN}-config-netbook \
+ ${PN}-config-scaleable \
+ ${PN}-config-standard \
+ ${PN}-theme-default \
+ ${PN}-background-dark-gradient \
+ ${PN}-background-light-gradient \
+ ${PN}-backgrounds \
+ ${PN}-images \
+ ${PN}-icons \
+ ${PN}-other \
+ ${PN}-input-methods \
+ ${PN}-sysactions \
+ ${PN}-utils \
+ ${PN}-menu \
+ efm-desktop-icon \
+ illume-keyboard-default-alpha \
+ illume-keyboard-default-numeric \
+ illume-keyboard-default-terminal \
"
ESYSACTIONS ?= "${PN}-sysactions"
RRECOMMENDS_${PN} = "\
- ${PN}-config-default \
- ${PN}-images \
- ${PN}-icons \
- ${PN}-other \
- ${PN}-input-methods \
- ${ESYSACTIONS} \
+ ${PN}-config-default \
+ ${PN}-images \
+ ${PN}-icons \
+ ${PN}-other \
+ ${PN}-input-methods \
+ ${ESYSACTIONS} \
"
FILES_${PN} = "\
- ${bindir}/* \
- ${libdir}/enlightenment/utils/* \
- ${libdir}/enlightenment/modules/*/*.* \
- ${libdir}/enlightenment/modules/*/*/* \
- ${libdir}/enlightenment/modules/*/*/.order \
- ${libdir}/enlightenment/modules/keyboards/ignore_built_in_keyboards \
- ${libdir}/enlightenment/*plugins/*/*/* \
- ${libdir}/enlightenment/preload/e_precache.so \
- ${datadir}/enlightenment/data/icons \
- ${datadir}/enlightenment/data/favorites \
- ${datadir}/enlightenment/data/input_methods \
- ${datadir}/enlightenment/data/config/profile.cfg \
- ${datadir}/enlightenment/AUTHORS \
- ${datadir}/enlightenment/COPYING \
- ${datadir}/xsessions/enlightenment.desktop \
- ${sysconfdir}/xdg \
+ ${bindir}/* \
+ ${libdir}/enlightenment/utils/* \
+ ${libdir}/enlightenment/modules/*/*.* \
+ ${libdir}/enlightenment/modules/*/*/* \
+ ${libdir}/enlightenment/modules/*/*/.order \
+ ${libdir}/enlightenment/modules/keyboards/ignore_built_in_keyboards \
+ ${libdir}/enlightenment/*plugins/*/*/* \
+ ${libdir}/enlightenment/preload/e_precache.so \
+ ${datadir}/enlightenment/data/icons \
+ ${datadir}/enlightenment/data/favorites \
+ ${datadir}/enlightenment/data/input_methods \
+ ${datadir}/enlightenment/data/config/profile.cfg \
+ ${datadir}/enlightenment/AUTHORS \
+ ${datadir}/enlightenment/COPYING \
+ ${datadir}/xsessions/enlightenment.desktop \
+ ${sysconfdir}/xdg \
"
FILES_${PN}-config-default = "${datadir}/enlightenment/data/config/default"
@@ -148,53 +148,53 @@ FILES_${PN}-utils = "${libdir}/enlightenment/utils/*"
FILES_${PN}-menu = "${sysconfdir}/xdg/menus/applications.menu"
FILES_efm-desktop-icon = "\
- ${datadir}/applications/efm.desktop \
- ${datadir}/applications/enlightenment_filemanager.desktop \
- ${datadir}/icons/e-module-fileman.png \
+ ${datadir}/applications/efm.desktop \
+ ${datadir}/applications/enlightenment_filemanager.desktop \
+ ${datadir}/icons/e-module-fileman.png \
"
KEYBOARDS_DIR="${libdir}/enlightenment/modules/illume-keyboard/keyboards"
FILES_illume-keyboard-default-alpha = "\
- ${KEYBOARDS_DIR}/Default.kbd \
- ${KEYBOARDS_DIR}/alpha.png \
+ ${KEYBOARDS_DIR}/Default.kbd \
+ ${KEYBOARDS_DIR}/alpha.png \
"
FILES_illume-keyboard-default-numeric = "\
- ${KEYBOARDS_DIR}/Numbers.kbd \
- ${KEYBOARDS_DIR}/numeric.png \
+ ${KEYBOARDS_DIR}/Numbers.kbd \
+ ${KEYBOARDS_DIR}/numeric.png \
"
FILES_illume-keyboard-default-terminal = "\
- ${KEYBOARDS_DIR}/Terminal.kbd \
- ${KEYBOARDS_DIR}/qwerty.png \
+ ${KEYBOARDS_DIR}/Terminal.kbd \
+ ${KEYBOARDS_DIR}/qwerty.png \
"
RRECOMMENDS_${PN}-config-default = "${PN}-theme-default"
RRECOMMENDS_${PN}-config-mobile = "\
- illume-keyboard-default-alpha \
- illume-keyboard-default-numeric \
- illume-keyboard-default-terminal \
+ illume-keyboard-default-alpha \
+ illume-keyboard-default-numeric \
+ illume-keyboard-default-terminal \
"
RRECOMMENDS_${PN}-config-minimalist = "\
- ${PN}-background-light-gradient \
- ${PN}-theme-default \
+ ${PN}-background-light-gradient \
+ ${PN}-theme-default \
"
RRECOMMENDS_${PN}-config-netbook = "\
- ${PN}-background-dark-gradient \
- ${PN}-theme-default \
+ ${PN}-background-dark-gradient \
+ ${PN}-theme-default \
"
RRECOMMENDS_${PN}-config-scaleable = "${PN}-theme-default"
RRECOMMENDS_${PN}-config-standard = "${PN}-theme-default"
FILES_${PN}-dbg += "\
- ${libdir}/enlightenment/modules/*/*/.debug/ \
- ${libdir}/enlightenment/modules/policies/.debug/ \
- ${libdir}/enlightenment/preload/.debug/ \
- ${libdir}/enlightenment/utils/.debug/ \
- ${libdir}/enlightenment/*plugins/*/*/.debug \
+ ${libdir}/enlightenment/modules/*/*/.debug/ \
+ ${libdir}/enlightenment/modules/policies/.debug/ \
+ ${libdir}/enlightenment/preload/.debug/ \
+ ${libdir}/enlightenment/utils/.debug/ \
+ ${libdir}/enlightenment/*plugins/*/*/.debug \
"
FILES_${PN}-doc += "\
- ${datadir}/enlightenment/doc \
+ ${datadir}/enlightenment/doc \
"
CONFFILES_${PN}-menu = "${sysconfdir}/xdg/menus/applications.menu"
diff --git a/meta-efl/recipes-efl/e17/e-wm_0.17.2.1.bb b/meta-efl/recipes-efl/e17/e-wm_0.17.2.1.bb
index ebd5900f95..228c12283a 100644
--- a/meta-efl/recipes-efl/e17/e-wm_0.17.2.1.bb
+++ b/meta-efl/recipes-efl/e17/e-wm_0.17.2.1.bb
@@ -7,9 +7,9 @@ SRCNAME = "enlightenment"
S = "${WORKDIR}/${SRCNAME}-${PV}"
SRC_URI = "\
- ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
- file://enlightenment_start.oe \
- file://applications.menu \
+ ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
+ file://enlightenment_start.oe \
+ file://applications.menu \
"
SRC_URI[md5sum] = "e78018ba7a4622efbcbebd6d093b7fa4"
diff --git a/meta-efl/recipes-efl/e17/e-wm_svn.bb b/meta-efl/recipes-efl/e17/e-wm_svn.bb
index 22eb821f77..fc03ff3e36 100644
--- a/meta-efl/recipes-efl/e17/e-wm_svn.bb
+++ b/meta-efl/recipes-efl/e17/e-wm_svn.bb
@@ -10,7 +10,7 @@ SRCREV = "${EFL_SRCREV}"
S = "${WORKDIR}/${SRCNAME}"
SRC_URI = "\
- ${E_SVN}/trunk;module=${SRCNAME};protocol=http \
- file://enlightenment_start.oe \
- file://applications.menu \
+ ${E_SVN}/trunk;module=${SRCNAME};protocol=http \
+ file://enlightenment_start.oe \
+ file://applications.menu \
"
diff --git a/meta-efl/recipes-efl/e17/elmdentica_svn.bb b/meta-efl/recipes-efl/e17/elmdentica_svn.bb
index f3bf939eb4..543b9b7042 100644
--- a/meta-efl/recipes-efl/e17/elmdentica_svn.bb
+++ b/meta-efl/recipes-efl/e17/elmdentica_svn.bb
@@ -19,5 +19,5 @@ SRCREV = "${EFL_SRCREV}"
RDEPENDS_${PN} = "${PN}-themes"
do_configure_prepend() {
- autopoint --force
+ autopoint --force
}
diff --git a/meta-efl/recipes-efl/e17/enjoy_svn.bb b/meta-efl/recipes-efl/e17/enjoy_svn.bb
index 5137c4edc4..bdbe471e53 100644
--- a/meta-efl/recipes-efl/e17/enjoy_svn.bb
+++ b/meta-efl/recipes-efl/e17/enjoy_svn.bb
@@ -18,12 +18,12 @@ RDEPENDS_${PN} += "\
gst-plugins-base-ogg gst-plugins-base-ivorbisdec \
gst-plugins-good-flac \
lightmediascanner-test \
- "
+"
inherit e gettext
SRC_URI = " \
- ${E_SVN}/trunk;module=${SRCNAME};protocol=http;scmdata=keep \
- file://0001-always-use-position-as-percent-and-define-a-1-second.patch \
+ ${E_SVN}/trunk;module=${SRCNAME};protocol=http;scmdata=keep \
+ file://0001-always-use-position-as-percent-and-define-a-1-second.patch \
"
S = "${WORKDIR}/${SRCNAME}"
@@ -32,11 +32,11 @@ PR = "r1"
FILES_${PN} += "${datadir}/icons/"
EXTRA_OECONF = "\
- --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+ --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
"
do_configure_prepend() {
- autopoint || touch config.rpath
+ autopoint || touch config.rpath
}
pkg_postinst_${PN} () {
diff --git a/meta-efl/recipes-efl/e17/eve_svn.bb b/meta-efl/recipes-efl/e17/eve_svn.bb
index 9f4b93b88e..128bd1ab00 100644
--- a/meta-efl/recipes-efl/e17/eve_svn.bb
+++ b/meta-efl/recipes-efl/e17/eve_svn.bb
@@ -10,16 +10,16 @@ SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};protocol=http;scmdata=keep"
S = "${WORKDIR}/${SRCNAME}"
do_configure_prepend() {
- autopoint || touch config.rpath
+ autopoint || touch config.rpath
}
SRC_URI += "file://eve-theme-for-smaller-screens.patch \
"
EXTRA_OECONF = "\
- --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+ --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
"
FILES_${PN} += "\
- ${datadir}/icons/eve.png \
+ ${datadir}/icons/eve.png \
"
diff --git a/meta-efl/recipes-efl/e17/exquisite-theme-illume.bb b/meta-efl/recipes-efl/e17/exquisite-theme-illume.bb
index 9037f688b3..5948e20731 100644
--- a/meta-efl/recipes-efl/e17/exquisite-theme-illume.bb
+++ b/meta-efl/recipes-efl/e17/exquisite-theme-illume.bb
@@ -21,7 +21,7 @@ SRC_URI = "${E_SVN}/trunk/THEMES;module=${SRCNAME};protocol=http \
S = "${WORKDIR}/${SRCNAME}"
do_compile() {
- ${STAGING_BINDIR_NATIVE}/edje_cc exquisite.edc illume.edj
+ ${STAGING_BINDIR_NATIVE}/edje_cc exquisite.edc illume.edj
}
do_install() {
diff --git a/meta-efl/recipes-efl/e17/exquisite_svn.bb b/meta-efl/recipes-efl/e17/exquisite_svn.bb
index 62453b8295..7dfb8e41ea 100644
--- a/meta-efl/recipes-efl/e17/exquisite_svn.bb
+++ b/meta-efl/recipes-efl/e17/exquisite_svn.bb
@@ -21,18 +21,18 @@ SRC_URI += "file://splashfuncs"
inherit update-rc.d
do_install_prepend() {
- install -d ${D}/mnt/.splash/
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/exquisite-init ${D}${sysconfdir}/init.d/exquisite
- install -d ${D}${sysconfdir}/default
- install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
- install -d ${D}${bindir}
- ln -s exquisite-write ${D}${bindir}/splash-write
+ install -d ${D}/mnt/.splash/
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/exquisite-init ${D}${sysconfdir}/init.d/exquisite
+ install -d ${D}${sysconfdir}/default
+ install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
+ install -d ${D}${bindir}
+ ln -s exquisite-write ${D}${bindir}/splash-write
}
do_install_append() {
- rm -rf ${D}${datadir}/exquisite/data/fonts/*
+ rm -rf ${D}${datadir}/exquisite/data/fonts/*
}
INITSCRIPT_NAME = "exquisite"
diff --git a/meta-efl/recipes-efl/e17/terminology.inc b/meta-efl/recipes-efl/e17/terminology.inc
index 15af6ea50e..00b8f834ac 100644
--- a/meta-efl/recipes-efl/e17/terminology.inc
+++ b/meta-efl/recipes-efl/e17/terminology.inc
@@ -10,11 +10,11 @@ INC_PR = "r2"
PE = "2"
EXTRA_OECONF = "\
- --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+ --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
"
FILES_${PN} += "\
- ${datadir}/icons/terminology.png \
+ ${datadir}/icons/terminology.png \
"
# doesn't start without own theme
diff --git a/meta-efl/recipes-efl/e17/terminology_0.3.0.bb b/meta-efl/recipes-efl/e17/terminology_0.3.0.bb
index 5bd485bd96..d3cd59cff7 100644
--- a/meta-efl/recipes-efl/e17/terminology_0.3.0.bb
+++ b/meta-efl/recipes-efl/e17/terminology_0.3.0.bb
@@ -3,7 +3,7 @@ require ${BPN}.inc
PR = "${INC_PR}.0"
SRC_URI = "\
- ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
+ ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
"
SRC_URI[md5sum] = "7cecd058cb4509873412252477f2ce5b"