aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/e17/eve_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-efl/recipes-efl/e17/eve_git.bb')
-rw-r--r--meta-efl/recipes-efl/e17/eve_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/e17/eve_git.bb b/meta-efl/recipes-efl/e17/eve_git.bb
new file mode 100644
index 0000000000..7879d6a8fc
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/eve_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Enlightenment Web Browser"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
+DEPENDS = "evas ecore edje elementary webkit-efl eldbus"
+
+PE = "1"
+PV = "0.3.0+gitr${SRCPV}"
+SRCREV = "7bd6549982f4fc5e26e5d11e6c536601358892e3"
+
+# webkit-efl isn't available for < armv7a
+COMPATIBLE_MACHINE = "(-)"
+COMPATIBLE_MACHINE_i586 = "(.*)"
+COMPATIBLE_MACHINE_x86-64 = "(.*)"
+COMPATIBLE_MACHINE_armv7a = "(.*)"
+
+inherit e gettext
+SRC_URI = " \
+ git://git.enlightenment.org/apps/${BPN}.git \
+ file://0001-eve-theme-updated-for-Openmoko-Freerunner-screen.patch \
+ file://0002-adapt-to-webkit-efl-changes.patch \
+"
+S = "${WORKDIR}/git"
+
+do_configure_prepend() {
+ autopoint || touch config.rpath
+}
+
+EXTRA_OECONF = "\
+ --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+"
+
+FILES_${PN} += "\
+ ${datadir}/icons/eve.png \
+"