aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
index 78b943247d..bbba576caa 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
@@ -20,6 +20,10 @@ inherit autotools-brokensep pkgconfig binconfig
# deprecated auto_ptr. For now, ignore the issue.
CXXFLAGS += "-Wno-error=deprecated-declarations"
+do_install_append () {
+ sed -i 's,${STAGING_DIR_TARGET},,g' ${D}${libdir}/pkgconfig/curlpp.pc
+}
+
PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
FILES_lib${BPN} = "${libdir}/lib*.so.* \