aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb2
-rw-r--r--meta-oe/recipes-support/libiio/libiio_0.25.bb1
-rw-r--r--meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb2
-rw-r--r--meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-astor_0.8.1.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-dbussy_1.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-gcovr_7.2.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-geomet_1.1.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-inotify_git.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-keras-applications_1.0.8.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-lrparsing_1.0.17.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-monotonic_1.6.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-pymetno_0.12.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb2
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb2
-rw-r--r--meta-python/recipes-extended/python-cson/python3-cson_git.bb2
-rw-r--r--meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb2
26 files changed, 0 insertions, 47 deletions
diff --git a/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb b/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
index e129c18d63..a98dfab6d9 100644
--- a/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
+++ b/meta-oe/recipes-devtools/python/python3-distutils-extra_2.39.bb
@@ -10,8 +10,6 @@ SRC_URI[sha256sum] = "723f24f4d65fc8d99b33a002fbbb3771d4cc9d664c97085bf37f3997ae
inherit setuptools3
-PIP_INSTALL_PACKAGE = "python_distutils_extra"
-
S = "${WORKDIR}/python-distutils-extra-${PV}"
BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-support/libiio/libiio_0.25.bb b/meta-oe/recipes-support/libiio/libiio_0.25.bb
index 9f3fcc0087..2c6d2b5145 100644
--- a/meta-oe/recipes-support/libiio/libiio_0.25.bb
+++ b/meta-oe/recipes-support/libiio/libiio_0.25.bb
@@ -73,7 +73,6 @@ do_compile() {
cmake_do_compile
}
-PIP_INSTALL_PACKAGE = "pylibiio"
do_install() {
if ${@bb.utils.contains('PACKAGECONFIG', 'libiio-python3', 'true', 'false', d)}; then
setuptools3_do_install
diff --git a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
index ef1b6e537b..c5dfff2259 100644
--- a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
+++ b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
@@ -10,8 +10,6 @@ SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f489
inherit setuptools3
-PIP_INSTALL_DIST_PATH = "${B}/python/python3/dist"
-
SETUPTOOLS_SETUP_PATH = "${S}/python"
do_install:append() {
diff --git a/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb b/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
index ef6375546e..ab39606bdb 100644
--- a/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
+++ b/meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb
@@ -17,5 +17,3 @@ SRCREV= "88cf6d9b9b685ffa1720644bd53c742afb10a414"
S = "${WORKDIR}/git"
inherit setuptools3
-
-PIP_INSTALL_PACKAGE = "txWS"
diff --git a/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb b/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb
index 54e43e3754..bc3315f751 100644
--- a/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-astor_0.8.1.bb
@@ -10,7 +10,6 @@ SRC_URI = "git://github.com/berkerpeksag/astor.git;branch=master;protocol=https
SRCREV ?= "c7553c79f9222e20783fe9bd8a553f932e918072"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "astor"
S = "${WORKDIR}/git"
diff --git a/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb b/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
index bcb68d7714..ac76ccc96a 100644
--- a/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
@@ -7,7 +7,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e3155c7bdc71f66e02678411d2abf996"
SRC_URI[sha256sum] = "78e73e19c63f5b20ffa567001531680d939dc042bf7850431877645523c66709"
PYPI_PACKAGE = "python-dateutil"
-PIP_INSTALL_PACKAGE = "python_dateutil"
inherit pypi python_setuptools_build_meta
PACKAGES =+ "${PN}-zoneinfo"
diff --git a/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb b/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb
index b1ba953922..59da4545aa 100644
--- a/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-dbussy_1.3.bb
@@ -12,8 +12,6 @@ S = "${WORKDIR}/git"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "DBussy"
-
RDEPENDS:${PN} += "\
python3-asyncio \
python3-core \
diff --git a/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb b/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb
index 2965e2f097..8a61a2de05 100644
--- a/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb
+++ b/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb
@@ -10,7 +10,6 @@ SRCREV = "c4b74b0859611283be646d590c7915e787911b6f"
S = "${WORKDIR}/git"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "gcovr"
RDEPENDS:${PN} += "python3-jinja2 python3-lxml python3-setuptools python3-pygments python3-multiprocessing"
diff --git a/meta-python/recipes-devtools/python/python3-geomet_1.1.0.bb b/meta-python/recipes-devtools/python/python3-geomet_1.1.0.bb
index bdf4fc5386..ceba10b65b 100644
--- a/meta-python/recipes-devtools/python/python3-geomet_1.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-geomet_1.1.0.bb
@@ -13,7 +13,6 @@ SRC_URI = "git://github.com/geomet/geomet.git;protocol=https;branch=master"
SRCREV = "6ac73c312b52aca328db2e61d90c5e363b62639f"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "geomet"
RDEPENDS:${PN} += "\
python3-click \
diff --git a/meta-python/recipes-devtools/python/python3-inotify_git.bb b/meta-python/recipes-devtools/python/python3-inotify_git.bb
index 657f610bdd..582599bca8 100644
--- a/meta-python/recipes-devtools/python/python3-inotify_git.bb
+++ b/meta-python/recipes-devtools/python/python3-inotify_git.bb
@@ -16,9 +16,6 @@ SRCREV = "9be6a51d1660991562eefaaddefa757ca0e0e00f"
S = "${WORKDIR}/git"
inherit setuptools3 ptest
-PIP_INSTALL_PACKAGE = "inotify"
-PIP_INSTALL_DIST_PATH = "${S}/dist"
-
RDEPENDS:${PN} += " \
python3-ctypes \
diff --git a/meta-python/recipes-devtools/python/python3-keras-applications_1.0.8.bb b/meta-python/recipes-devtools/python/python3-keras-applications_1.0.8.bb
index 6c2af0d4ea..ba1819979b 100644
--- a/meta-python/recipes-devtools/python/python3-keras-applications_1.0.8.bb
+++ b/meta-python/recipes-devtools/python/python3-keras-applications_1.0.8.bb
@@ -7,11 +7,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=366e2fd3c9714f162d3663b6f97cfe41"
SRC_URI = "git://github.com/keras-team/keras-applications.git;branch=master;protocol=https"
SRCREV ?= "3b180cb10eda683dda7913ecee2e6487288d292d"
-
inherit setuptools3
-PIP_INSTALL_PACKAGE = "Keras_Applications"
-
S = "${WORKDIR}/git"
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
index 9e791c6e78..991aa0f7d8 100644
--- a/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-kivy_2.3.0.bb
@@ -5,7 +5,6 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=6d3bc49400e35d5a2279d14c40dcfb09"
inherit setuptools3 pkgconfig features_check
-PIP_INSTALL_PACKAGE = "Kivy"
# Kivy's setup files only look for GLES libraries for Android, iOS, RPi,
# and mali-based OS's. We need to patch the setup file to tell Kivy setup
diff --git a/meta-python/recipes-devtools/python/python3-lrparsing_1.0.17.bb b/meta-python/recipes-devtools/python/python3-lrparsing_1.0.17.bb
index 673d32c2d4..8cd60d3a0f 100644
--- a/meta-python/recipes-devtools/python/python3-lrparsing_1.0.17.bb
+++ b/meta-python/recipes-devtools/python/python3-lrparsing_1.0.17.bb
@@ -17,7 +17,6 @@ RDEPENDS:${PN} = " \
"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "lrparsing"
S = "${WORKDIR}/lrparsing-${PV}"
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb
index 5a0a79a541..bf1d8dd290 100644
--- a/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb
+++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb
@@ -10,8 +10,6 @@ SRC_URI[sha256sum] = "4e65e9e0d80fc9e609574b9983cf32579f305c718afb30d7233ab81857
inherit python_flit_core pypi ptest
-PIP_INSTALL_PACKAGE = "marshmallow"
-
SRC_URI += " \
file://run-ptest \
"
diff --git a/meta-python/recipes-devtools/python/python3-monotonic_1.6.bb b/meta-python/recipes-devtools/python/python3-monotonic_1.6.bb
index 2af7b57921..aacc32a6d6 100644
--- a/meta-python/recipes-devtools/python/python3-monotonic_1.6.bb
+++ b/meta-python/recipes-devtools/python/python3-monotonic_1.6.bb
@@ -11,5 +11,3 @@ SRC_URI = "git://github.com/atdt/monotonic.git;branch=master;protocol=https"
S = "${WORKDIR}/git"
inherit setuptools3
-
-PIP_INSTALL_PACKAGE = "monotonic"
diff --git a/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb b/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
index f3e0711087..50dae7b407 100644
--- a/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
+++ b/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
@@ -7,9 +7,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=38066667888b01d8118ff9cc23da1873"
inherit setuptools3 pypi ptest
SRC_URI[sha256sum] = "82e6114004b3d6911c77c3953e3838654b04511b8b66e8583db70c65998017dc"
-PIP_INSTALL_PACKAGE = "pefile"
-PIP_INSTALL_DIST_PATH = "${S}/dist"
-
BBCLASSEXTEND = "native nativesdk"
RDEPENDS:${PN} += " \
diff --git a/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb b/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
index 91b02ea017..e795bd4916 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
@@ -14,9 +14,6 @@ SRCREV ?= "da59ad000d1405eaecd557175e29083a87d19f7c"
inherit setuptools3 ptest
-PIP_INSTALL_PACKAGE = "Pillow"
-PIP_INSTALL_DIST_PATH = "${S}/dist"
-
DEPENDS += " \
zlib \
jpeg \
diff --git a/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb b/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
index a45ef45f32..a4732993f8 100644
--- a/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
@@ -15,7 +15,6 @@ SRC_URI = "git://github.com/seveas/python-prctl;protocol=https;branch=main \
file://0001-support-cross-complication.patch \
"
inherit setuptools3 python3native
-PIP_INSTALL_PACKAGE = "python_prctl"
DEPENDS += "libcap"
diff --git a/meta-python/recipes-devtools/python/python3-pymetno_0.12.0.bb b/meta-python/recipes-devtools/python/python3-pymetno_0.12.0.bb
index 97985a8a1d..5be6e6319b 100644
--- a/meta-python/recipes-devtools/python/python3-pymetno_0.12.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pymetno_0.12.0.bb
@@ -9,8 +9,6 @@ S = "${WORKDIR}/git"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "PyMetno"
-
RDEPENDS:${PN} = "\
python3-aiohttp (>=3.6.1) \
python3-async-timeout (>=3.0.1) \
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb
index dcde77db08..e9000dd479 100644
--- a/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.186.bb
@@ -7,8 +7,6 @@ SRC_URI[sha256sum] = "bdf2d54b297ad890418179b044dd4ea79821fccef723823919d12262e9
inherit python_poetry_core pypi
-PIP_INSTALL_PACKAGE = "pymisp"
-
RDEPENDS:${PN} += " \
python3-dateutil \
python3-json \
diff --git a/meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb b/meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb
index 7a96635144..2807c054d9 100644
--- a/meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyruvate_1.2.1.bb
@@ -24,8 +24,6 @@ S = "${WORKDIR}/git"
inherit python_setuptools3_rust cargo-update-recipe-crates
-PIP_INSTALL_DIST_PATH = "${S}/dist"
-
# crossbeam-* -> std::sync::atomic AtomicI64, AtomicU64
# not supported on mips/powerpc with 32-bit pointers
# https://doc.rust-lang.org/std/sync/atomic/#portability
diff --git a/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb b/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb
index 7373b02f53..b6680568b4 100644
--- a/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb
+++ b/meta-python/recipes-devtools/python/python3-slip-dbus_0.6.5.bb
@@ -34,4 +34,3 @@ RDEPENDS:${PN} += "\
CLEANBROKEN = "1"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "slip"
diff --git a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
index 8a9af14d3e..aedf483bef 100644
--- a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
@@ -17,8 +17,6 @@ SRCREV = "b8d573e11ec149da695d695c81a156232b89a949"
S = "${WORKDIR}/git"
inherit ptest setuptools3
-PIP_INSTALL_PACKAGE = "xlrd"
-PIP_INSTALL_DIST_PATH = "${S}/dist"
RDEPENDS:${PN} += " \
python3-compression \
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
index b6e04e081e..7c30f5630d 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.4.2.bb
@@ -13,8 +13,6 @@ S = "${WORKDIR}/git"
inherit features_check setuptools3
REQUIRED_DISTRO_FEATURES = "x11 systemd gobject-introspection-data"
-PIP_INSTALL_PACKAGE = "blivet_gui"
-
RDEPENDS:${PN} = "python3-pygobject python3 \
python3-blivet gtk+3 \
python3-pid libreport \
diff --git a/meta-python/recipes-extended/python-cson/python3-cson_git.bb b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
index aba1d8fff3..489733c767 100644
--- a/meta-python/recipes-extended/python-cson/python3-cson_git.bb
+++ b/meta-python/recipes-extended/python-cson/python3-cson_git.bb
@@ -18,8 +18,6 @@ RDEPENDS:${PN} = "python3-json"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "python_cson"
-
do_configure:prepend() {
echo "__version__=${PV}" > ${S}/version.py
}
diff --git a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb
index 3c6c478328..953068f7c3 100644
--- a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb
+++ b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb
@@ -23,5 +23,3 @@ SRCREV = "fa6c80c0e5c6bee29d089899a10d26e6f7f8afd8"
UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "pykickstart"
-PIP_INSTALL_DIST_PATH = "${S}/dist"