aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-graphics/tesseract/tesseract/0001-include-sys-time.h.patch34
-rw-r--r--meta-oe/recipes-graphics/tesseract/tesseract_4.1.1.bb (renamed from meta-oe/recipes-graphics/tesseract/tesseract_git.bb)15
2 files changed, 43 insertions, 6 deletions
diff --git a/meta-oe/recipes-graphics/tesseract/tesseract/0001-include-sys-time.h.patch b/meta-oe/recipes-graphics/tesseract/tesseract/0001-include-sys-time.h.patch
new file mode 100644
index 0000000000..de1fa75b7c
--- /dev/null
+++ b/meta-oe/recipes-graphics/tesseract/tesseract/0001-include-sys-time.h.patch
@@ -0,0 +1,34 @@
+From b47fa9532a7090d76521603dbc818bdec100085f Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 15 Sep 2020 17:04:27 -0700
+Subject: [PATCH] include sys/time.h
+
+This provides missing definitions of timeval stuct
+
+Fixes
+| ../../../git/src/ccutil/ocrclass.h:154:7: error: member access into
+incomplete type 'struct timeval'
+| tv->tv_usec = (millisecs.count() % 1000) * 1000;
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/ccutil/ocrclass.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/ccutil/ocrclass.h b/src/ccutil/ocrclass.h
+index d39a6dd6..96395c9b 100644
+--- a/src/ccutil/ocrclass.h
++++ b/src/ccutil/ocrclass.h
+@@ -28,6 +28,8 @@
+
+ #include <chrono>
+ #include <ctime>
++#include <sys/time.h>
++
+ #ifdef _WIN32
+ #include <winsock2.h> // for timeval
+ #endif
+--
+2.28.0
+
diff --git a/meta-oe/recipes-graphics/tesseract/tesseract_git.bb b/meta-oe/recipes-graphics/tesseract/tesseract_4.1.1.bb
index 89d09a0f55..3b5032f06d 100644
--- a/meta-oe/recipes-graphics/tesseract/tesseract_git.bb
+++ b/meta-oe/recipes-graphics/tesseract/tesseract_4.1.1.bb
@@ -1,19 +1,22 @@
SUMMARY = "A commercial quality OCR engine "
+HOMEPAGE = "https://github.com/tesseract-ocr/tesseract"
+BUGTRACKER = "https://github.com/tesseract-ocr/tesseract/issues"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=7ea4f9a43aba9d3c849fe5c203a0ed40"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+BRANCH = "4.1"
+SRCREV = "f4ef2f2050f4c25b28bdbf0063b7d2eb30f41cf7"
+SRC_URI = "git://github.com/${BPN}-ocr/${BPN}.git;branch=${BRANCH} \
+ file://0001-include-sys-time.h.patch \
+ "
-BRANCH = "3.05"
-PV = "${BRANCH}.01+git${SRCPV}"
-SRCREV = "215866151e774972c9502282111b998d7a053562"
-SRC_URI = "git://github.com/${BPN}-ocr/${BPN}.git;branch=${BRANCH}"
S = "${WORKDIR}/git"
DEPENDS = "leptonica"
EXTRA_OECONF += "LIBLEPT_HEADERSDIR=${STAGING_INCDIR}/leptonica"
-
inherit autotools pkgconfig
FILES_${PN} += "${datadir}/tessdata"