aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-graphics/libagg/libagg/0001-fix-configure-ac.patch18
-rw-r--r--meta-oe/recipes-graphics/libagg/libagg_2.4.0.bb30
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libagg/libagg/0001-fix-configure-ac.patch b/meta-oe/recipes-graphics/libagg/libagg/0001-fix-configure-ac.patch
new file mode 100644
index 0000000000..46b84077de
--- /dev/null
+++ b/meta-oe/recipes-graphics/libagg/libagg/0001-fix-configure-ac.patch
@@ -0,0 +1,18 @@
+AM_C_PROTOTYPES throws an error, replace with AC_C_PROTOTYPES
+
+Upstream-Status: Pending
+Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
+
+Index: agg-2.4/configure.ac
+===================================================================
+--- agg-2.4.orig/configure.ac
++++ agg-2.4/configure.ac
+@@ -8,7 +8,7 @@ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_CXX
+ AC_ISC_POSIX
+-AM_C_PROTOTYPES
++AC_C_PROTOTYPES
+ if test "x$U" != "x"; then
+ AC_MSG_ERROR(Compiler not ANSI compliant)
+ fi
diff --git a/meta-oe/recipes-graphics/libagg/libagg_2.4.0.bb b/meta-oe/recipes-graphics/libagg/libagg_2.4.0.bb
new file mode 100644
index 0000000000..0a4b10116e
--- /dev/null
+++ b/meta-oe/recipes-graphics/libagg/libagg_2.4.0.bb
@@ -0,0 +1,30 @@
+# Recipe created by recipetool
+# This is the basis of a recipe and may need further editing in order to be fully functional.
+# (Feel free to remove these comments when editing.)
+
+# Unable to find any files that looked like license statements. Check the accompanying
+# documentation and source headers and set LICENSE and LIC_FILES_CHKSUM accordingly.
+#
+# NOTE: LICENSE is being set to "CLOSED" to allow you to at least start building - if
+# this is not accurate with respect to the licensing of the software being built (it
+# will not be in most cases) you must specify the correct value before using this
+# recipe for anything other than initial testing/development!
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+SRC_URI = " \
+ svn://svn.code.sf.net/p/agg/svn/;module=agg-2.4;rev=127;protocol=https \
+ file://0001-fix-configure-ac.patch"
+
+S = "${WORKDIR}/agg-2.4"
+
+DEPENDS = "freetype libsdl libx11"
+
+# NOTE: if this software is not capable of being built in a separate build directory
+# from the source, you should replace autotools with autotools-brokensep in the
+# inherit line
+inherit pkgconfig autotools
+
+# Specify any options you want to pass to the configure script using EXTRA_OECONF:
+EXTRA_OECONF = ""
+