aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-ordered-set/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-ordered-set_3.1.1.bb14
2 files changed, 16 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest b/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
new file mode 100644
index 0000000000..f7b9d0907c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest test.py
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set_3.1.1.bb b/meta-python/recipes-devtools/python/python3-ordered-set_3.1.1.bb
index 013a2e7559..bf362daa7c 100644
--- a/meta-python/recipes-devtools/python/python3-ordered-set_3.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-ordered-set_3.1.1.bb
@@ -6,6 +6,18 @@ LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=2b36be0d99854aa2ae292a800a7c1d4e"
SRC_URI[md5sum] = "6e12312c8dc4c90fe840e86e8a352644"
SRC_URI[sha256sum] = "a7bfa858748c73b096e43db14eb23e2bc714a503f990c89fac8fab9b0ee79724"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
DEPENDS += "python3-pytest-runner-native"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test.py ${D}${PTEST_PATH}/
+}