aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend b/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend
index 91814e6cde..abfda60658 100644
--- a/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend
+++ b/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend
@@ -1,2 +1,12 @@
# Main recipe was moved to oe-core, but with ptest disabled
inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)}
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+