aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/augeas/augeas/0001-Unset-need_charset_alias-when-building-for-musl.patch13
-rw-r--r--meta-oe/recipes-support/augeas/augeas/add-missing-argz-conditional.patch17
-rw-r--r--meta-oe/recipes-support/augeas/augeas/sepbuildfix.patch23
3 files changed, 35 insertions, 18 deletions
diff --git a/meta-oe/recipes-support/augeas/augeas/0001-Unset-need_charset_alias-when-building-for-musl.patch b/meta-oe/recipes-support/augeas/augeas/0001-Unset-need_charset_alias-when-building-for-musl.patch
index 9a19876aa6..0ba7c76a36 100644
--- a/meta-oe/recipes-support/augeas/augeas/0001-Unset-need_charset_alias-when-building-for-musl.patch
+++ b/meta-oe/recipes-support/augeas/augeas/0001-Unset-need_charset_alias-when-building-for-musl.patch
@@ -1,4 +1,4 @@
-From b9565dc2fe0c4f7daaec91b7e83bc7313dee2f4a Mon Sep 17 00:00:00 2001
+From 32b15332e2130a54b25f4fbf6f58b407b851dd8f Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Mon, 13 Apr 2015 17:02:13 -0700
Subject: [PATCH] Unset need_charset_alias when building for musl
@@ -11,14 +11,15 @@ coreutils
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
- lib/gnulib.mk | 2 +-
+ gnulib/lib/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-Index: augeas-1.2.0/gnulib/lib/Makefile.am
-===================================================================
---- augeas-1.2.0.orig/gnulib/lib/Makefile.am
-+++ augeas-1.2.0/gnulib/lib/Makefile.am
+diff --git a/gnulib/lib/Makefile.am b/gnulib/lib/Makefile.am
+index 963b22d..75788d2 100644
+--- a/gnulib/lib/Makefile.am
++++ b/gnulib/lib/Makefile.am
@@ -463,7 +463,7 @@ install-exec-localcharset: all-local
case '$(host_os)' in \
darwin[56]*) \
diff --git a/meta-oe/recipes-support/augeas/augeas/add-missing-argz-conditional.patch b/meta-oe/recipes-support/augeas/augeas/add-missing-argz-conditional.patch
index abbdbaa63b..368bb41764 100644
--- a/meta-oe/recipes-support/augeas/augeas/add-missing-argz-conditional.patch
+++ b/meta-oe/recipes-support/augeas/augeas/add-missing-argz-conditional.patch
@@ -1,14 +1,21 @@
-Add missing GL_GENERATE_ARGZ_H conditional
+From 9a6e6374da7d7056db0950f0f7d6b8b905009775 Mon Sep 17 00:00:00 2001
+From: Constantin Musca <constantinx.musca@intel.com>
+Date: Fri, 15 Jul 2016 10:04:48 +0300
+Subject: [PATCH] Add missing GL_GENERATE_ARGZ_H conditional
- GL_GENERATE_ARGZ_H is used in gnulib/lib/Makefile.am
Upstream-Status: Pending
Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
-Index: augeas-1.0.0/configure.ac
-===================================================================
---- augeas-1.0.0.orig/configure.ac
-+++ augeas-1.0.0/configure.ac
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 72b6984..fb9653e 100644
+--- a/configure.ac
++++ b/configure.ac
@@ -55,6 +55,8 @@ AC_ARG_WITH([failmalloc],
AM_CONDITIONAL([WITH_FAILMALLOC], [test x$with_failmalloc != xno])
diff --git a/meta-oe/recipes-support/augeas/augeas/sepbuildfix.patch b/meta-oe/recipes-support/augeas/augeas/sepbuildfix.patch
index b82a3ee2cb..2b18618fbc 100644
--- a/meta-oe/recipes-support/augeas/augeas/sepbuildfix.patch
+++ b/meta-oe/recipes-support/augeas/augeas/sepbuildfix.patch
@@ -1,15 +1,24 @@
-Ensure that builds in separate builddirs (${B} != ${S}) correctly install the
+From 8a277957a2579e7149c1850675441b288192077c Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Fri, 15 Jul 2016 10:04:48 +0300
+Subject: [PATCH] augeas: fix separate builddirs
+
+Ensure that builds in separate builddirs (${B} != ${S}) correctly install the
lenses files.
Upstream-Status: Pending
RP 2013/4/17
-Index: augeas-1.0.0/Makefile.am
-===================================================================
---- augeas-1.0.0.orig/Makefile.am 2012-11-02 15:20:11.000000000 +0000
-+++ augeas-1.0.0/Makefile.am 2013-04-17 10:36:24.033400125 +0000
-@@ -5,8 +5,8 @@
+---
+ Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 87d511a..7710b3b 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,8 +5,8 @@ ACLOCAL_AMFLAGS = -I gnulib/m4
lensdir=$(datadir)/augeas/lenses/dist
lenstestdir=$(datadir)/augeas/lenses/dist/tests
@@ -18,5 +27,5 @@ Index: augeas-1.0.0/Makefile.am
+dist_lens_DATA=$(wildcard $(top_srcdir)/lenses/*.aug)
+dist_lenstest_DATA=$(wildcard $(top_srcdir)lenses/tests/*.aug)
- EXTRA_DIST=augeas.spec build/aux/move-if-change Makefile.am HACKING
+ EXTRA_DIST=augeas.spec build/ac-aux/move-if-change Makefile.am HACKING.md