aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-flask-pymongo.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-flask-pymongo_0.4.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-pymongo_0.4.0.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-pymongo.inc b/meta-python/recipes-devtools/python/python-flask-pymongo.inc
new file mode 100644
index 0000000000..939113b5e7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-pymongo.inc
@@ -0,0 +1,13 @@
+SUMMARY = "PyMongo support for Flask applications"
+DESCRIPTION = "PyMongo support for Flask applications."
+HOMEPAGE = "https://github.com/mitsuhiko/flask/"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://flask_pymongo/wrappers.py;startline=1;endline=24;md5=dff998d5a8469503612ee7757f3a2052"
+
+SRC_URI[md5sum] = "457a210f35ba49d2623dbcf27fbb89e1"
+SRC_URI[sha256sum] = "707ddff92f5b7bdc34d401f1f3857a3d1a9f5dba76e6a1422ccbc3651e2ca521"
+
+PYPI_PACKAGE = "Flask-PyMongo"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-pymongo ${PYTHON_PN}-flask"
diff --git a/meta-python/recipes-devtools/python/python-flask-pymongo_0.4.0.bb b/meta-python/recipes-devtools/python/python-flask-pymongo_0.4.0.bb
new file mode 100644
index 0000000000..8daab002f0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-pymongo_0.4.0.bb
@@ -0,0 +1,2 @@
+inherit pypi
+require python-flask-pymongo.inc
diff --git a/meta-python/recipes-devtools/python/python3-flask-pymongo_0.4.0.bb b/meta-python/recipes-devtools/python/python3-flask-pymongo_0.4.0.bb
new file mode 100644
index 0000000000..19d33ff632
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-pymongo_0.4.0.bb
@@ -0,0 +1,2 @@
+inherit pypi3
+require python-flask-pymongo.inc