aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-core/toybox/toybox/0001-Fix-segfault-in-login.patch33
-rw-r--r--meta-oe/recipes-core/toybox/toybox/0002-Add-b-and-F-arguments-to-hostname.patch84
-rw-r--r--meta-oe/recipes-core/toybox/toybox_0.7.0.bb (renamed from meta-oe/recipes-core/toybox/toybox_0.6.0.bb)12
3 files changed, 125 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/toybox/toybox/0001-Fix-segfault-in-login.patch b/meta-oe/recipes-core/toybox/toybox/0001-Fix-segfault-in-login.patch
new file mode 100644
index 0000000000..939885b961
--- /dev/null
+++ b/meta-oe/recipes-core/toybox/toybox/0001-Fix-segfault-in-login.patch
@@ -0,0 +1,33 @@
+From 863b129441c12eb75d63e4f4fe9a8f7df81607fd Mon Sep 17 00:00:00 2001
+From: Paul Barker <paul@paulbarker.me.uk>
+Date: Sun, 1 May 2016 14:50:59 +0100
+Subject: [PATCH] Fix segfault in login
+
+Fix a bug in readfileat where *plen would be corrupted if you didn't supply
+your own buffer (because ibuf is 0 in that case, not a pointer to the start
+of the allocated space). This caused a segfault in the 'login' program.
+
+Partial backport of upstream commit 81f31e463bd982a8344ea8681938eb43c9114652
+
+Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
+Upstream-status: Backport
+---
+ lib/lib.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/lib.c b/lib/lib.c
+index 6559030..e5bb605 100644
+--- a/lib/lib.c
++++ b/lib/lib.c
+@@ -475,7 +475,7 @@ char *readfileat(int dirfd, char *name, char *ibuf, off_t *plen)
+ rbuf = buf+rlen;
+ len -= rlen;
+ }
+- *plen = len = rlen+(buf-ibuf);
++ *plen = len = rlen+(rbuf-buf);
+ close(fd);
+
+ if (rlen<0) {
+--
+2.1.4
+
diff --git a/meta-oe/recipes-core/toybox/toybox/0002-Add-b-and-F-arguments-to-hostname.patch b/meta-oe/recipes-core/toybox/toybox/0002-Add-b-and-F-arguments-to-hostname.patch
new file mode 100644
index 0000000000..e300494114
--- /dev/null
+++ b/meta-oe/recipes-core/toybox/toybox/0002-Add-b-and-F-arguments-to-hostname.patch
@@ -0,0 +1,84 @@
+From 151f576ab1fba44137beaeb95620b7942662b4d3 Mon Sep 17 00:00:00 2001
+From: Paul Barker <paul@paulbarker.me.uk>
+Date: Sun, 1 May 2016 15:42:57 +0100
+Subject: [PATCH] Add -b and -F arguments to hostname
+
+These arguments are required to correctly set the hostname at boot time.
+
+Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
+Upstream-status: Submitted
+---
+ toys/lsb/hostname.c | 42 ++++++++++++++++++++++++++++++++++++++++--
+ 1 file changed, 40 insertions(+), 2 deletions(-)
+
+diff --git a/toys/lsb/hostname.c b/toys/lsb/hostname.c
+index 23467fb..ebfc803 100644
+--- a/toys/lsb/hostname.c
++++ b/toys/lsb/hostname.c
+@@ -4,23 +4,61 @@
+ *
+ * http://refspecs.linuxfoundation.org/LSB_4.1.0/LSB-Core-generic/LSB-Core-generic/hostname.html
+
+-USE_HOSTNAME(NEWTOY(hostname, NULL, TOYFLAG_BIN))
++USE_HOSTNAME(NEWTOY(hostname, "bF:", TOYFLAG_BIN))
+
+ config HOSTNAME
+ bool "hostname"
+ default y
+ help
+- usage: hostname [newname]
++ usage: hostname [-b] [-F FILENAME] [newname]
+
+ Get/Set the current hostname
++
++ -b Set hostname to 'localhost' if otherwise unset
++ -F Set hostname to contents of FILENAME
+ */
+
+ #define FOR_hostname
+ #include "toys.h"
+
++GLOBALS(
++ char *fname;
++)
++
+ void hostname_main(void)
+ {
+ const char *hostname = toys.optargs[0];
++
++ if (toys.optflags & FLAG_F) {
++ char *buf;
++ if ((hostname = buf = readfile(TT.fname, 0, 0))) {
++ size_t len = strlen(hostname);
++ char *end = buf + len - 1;
++
++ /* Trim trailing whitespace. */
++ while (len && isspace(*end)) {
++ *end-- = '\0';
++ len--;
++ }
++ if (!len) {
++ free(buf);
++ hostname = NULL;
++ if (!(toys.optflags & FLAG_b))
++ error_exit("empty file '%s'", TT.fname);
++ }
++ } else if (!(toys.optflags & FLAG_b))
++ error_exit("failed to read '%s'", TT.fname);
++ }
++
++ if (!hostname && toys.optflags & FLAG_b) {
++ /* Do nothing if hostname already set. */
++ if (gethostname(toybuf, sizeof(toybuf))) perror_exit("get failed");
++ if (strnlen(toybuf, sizeof(toybuf))) exit(0);
++
++ /* Else set hostname to localhost. */
++ hostname = "localhost";
++ }
++
+ if (hostname) {
+ if (sethostname(hostname, strlen(hostname)))
+ perror_exit("set failed '%s'", hostname);
+--
+2.1.4
+
diff --git a/meta-oe/recipes-core/toybox/toybox_0.6.0.bb b/meta-oe/recipes-core/toybox/toybox_0.7.0.bb
index da03200b2d..d7b469a899 100644
--- a/meta-oe/recipes-core/toybox/toybox_0.6.0.bb
+++ b/meta-oe/recipes-core/toybox/toybox_0.7.0.bb
@@ -1,11 +1,15 @@
SUMMARY = "Toybox combines common utilities together into a single executable."
HOMEPAGE = "http://www.landley.net/toybox/"
+DEPENDS = "attr"
-SRC_URI = "http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "7f4a6c89e56c48e3350e611f5b36c2cf"
-SRC_URI[sha256sum] = "b6e2694d19ac08f1c3416d5b2a02a31d445db2ed98dec89761430cdff2c9710d"
+SRC_URI = " \
+ http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz \
+ file://0001-Fix-segfault-in-login.patch \
+ file://0002-Add-b-and-F-arguments-to-hostname.patch \
+"
+SRC_URI[md5sum] = "d86c78624b47625c2f0fc64eda599443"
+SRC_URI[sha256sum] = "65428816f88ad3fe92b67df86dc05427c8078fe03843b8b9715fdfa6d29c0f97"
LICENSE = "BSD-0-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f0b8b3dd6431bcaa245da0a08bd0d511"