aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pyelftools.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-pyelftools_0.25.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb2
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyelftools.inc b/meta-python/recipes-devtools/python/python-pyelftools.inc
new file mode 100644
index 0000000000..7d4f763ffd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyelftools.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "pyelftools is a pure-Python library for parsing and analyzing ELF files and DWARF debugging information"
+HOMEPAGE = "https://github.com/eliben/pyelftools"
+SECTION = "devel/python"
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5ce2a2b07fca326bc7c146d10105ccfc"
+
+SRC_URI[md5sum] = "c5629b9a5d19c82107a946cce52eeec2"
+SRC_URI[sha256sum] = "89c6da6f56280c37a5ff33468591ba9a124e17d71fe42de971818cbff46c1b24"
+
+PYPI_PACKAGE = "pyelftools"
+
+inherit pypi
+
+BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-pyelftools_0.25.bb b/meta-python/recipes-devtools/python/python-pyelftools_0.25.bb
new file mode 100644
index 0000000000..de42025060
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyelftools_0.25.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pyelftools.inc
diff --git a/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb b/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb
new file mode 100644
index 0000000000..56eb8c4cd6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pyelftools.inc