aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb b/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
index 038043c568..38d8122ce9 100644
--- a/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
@@ -1,2 +1,7 @@
inherit setuptools3
require python-chardet.inc
+
+do_install_append () {
+ # rename scripts that would conflict with the Python 2 build of chardet
+ mv ${D}${bindir}/chardetect ${D}${bindir}/chardetect3
+}