aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography-vectors.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography-vectors_1.4.bb16
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography-vectors_1.4.bb2
3 files changed, 19 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography-vectors.inc b/meta-python/recipes-devtools/python/python-cryptography-vectors.inc
new file mode 100644
index 0000000000..62dfbfd342
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography-vectors.inc
@@ -0,0 +1,15 @@
+SUMMARY = "Test vectors for the cryptography package."
+SECTION = "devel/python"
+LICENSE = "Apache-2.0 | BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
+
+DEPENDS = " \
+ ${PYTHON_PN}-cryptography \
+"
+
+SRC_URI[md5sum] = "b8555dfadafc4ecab4ee4650430d9cab"
+SRC_URI[sha256sum] = "0728815ef0c53d67fd437aa5220450a9752d41ecb28108f5df628a092ff466ea"
+
+PYPI_PACKAGE = "cryptography_vectors"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-cryptography-vectors_1.4.bb b/meta-python/recipes-devtools/python/python-cryptography-vectors_1.4.bb
index 0313c81dc0..4975278a99 100644
--- a/meta-python/recipes-devtools/python/python-cryptography-vectors_1.4.bb
+++ b/meta-python/recipes-devtools/python/python-cryptography-vectors_1.4.bb
@@ -1,14 +1,2 @@
-SUMMARY = "Test vectors for the cryptography package."
-SECTION = "devel/python"
-LICENSE = "Apache-2.0 | BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
-DEPENDS = "python-cryptography"
-SRCNAME = "cryptography_vectors"
-
-SRC_URI = "https://files.pythonhosted.org/packages/source/c/cryptography-vectors/${SRCNAME}-${PV}.tar.gz"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-SRC_URI[md5sum] = "b8555dfadafc4ecab4ee4650430d9cab"
-SRC_URI[sha256sum] = "0728815ef0c53d67fd437aa5220450a9752d41ecb28108f5df628a092ff466ea"
-
-inherit setuptools
+inherit pypi setuptools
+require python-cryptography-vectors.inc
diff --git a/meta-python/recipes-devtools/python/python3-cryptography-vectors_1.4.bb b/meta-python/recipes-devtools/python/python3-cryptography-vectors_1.4.bb
new file mode 100644
index 0000000000..58994ffffa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography-vectors_1.4.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-cryptography-vectors.inc